Finally solved: CC2531 can't connect to ZHA


first: I’m new here. Hello to all :slight_smile:
second: I’m only a user, no Linux expert

My infrastructure is a Synology DS218j NAS with the Home Assistant installation of the SynoCommunity.

I tried to connect a new CC2531 USB stick. ZHA recognizes it but I get the error message that no connection to the device is possible. I’m totally lost and all the hints I fount by searching with Google are that detailed in Linux configuration etc. I don’t see the steps I should do.

Hope somebody can support me.

Thanks in Advance

Did you buy it pre-flashed with compatible Z-Stack application firmware or have you flashed it yourself?

Same firmware requirements as Zigbee2MQTT. You need to flash it unless you bought it pre-flashed.

1 Like

I bought it pre-flashed with Z-Stack CC2531_DEFAULT_20190608

Is Zigbee2MQTT the same as ZHA interface or do I need to install it additionally to make the adapter work?

Suggest that you try it with zigpy-znp instead of with zigpy-cc as I think zigpy-cc is currently broken

Maybe even consider risk upgrading the stick firmware to Z-Stack 3.0.1 even though it is only “BETA”. Benifit is that Z-Stack 3.0.x supports Zigbee 3.0 and makes it easy to upgrade to newer hardware later.

" ( BETA ) CC2531 running Z-Stack 3.0.1. You can flash CC2531ZNP-without-SBL.bin to your stick directly with zigpy_znp : python -m -i /path/to/CC2531ZNP-without-SBL.bin /dev/serial/by-id/YOUR-CC2531 if your stick already has a serial bootloader "

They are not the same. Two different solutions. I just meant that they both support the same firmware and Zigbee2MQTT just so happen to have more documentation about how-to flash firmware to it.

Does this by the way mean that you install Home Assistant in Python directly under Synology DSM OS?

If so read Zigbee Home Automation - Home Assistant

However, I do not think that running HA directly in Synology DSM OS is recommended any longer?

Better to install HA on a Raspberry Pi 3/4 or if you have a Synology with Intel CPU or a other Intel machine with virualization support then you can install Home Assistant OS on a virtual machine. If so then you need make sure to re-direct the USB-port to the VM.

Hi and thanks for your answers. Unfortunately I was in calls the afternoon so I came back to my PC just yet.

#1: yes I installed HA directly in Snology because I have a Synology version with ARM processor and therefore no ready-to-install package for Docker is provided by Synology
#2: Having read all the information about Docker, I’m confused whether it will run on my NAS or not. I tried to work with Raspi in my last home, but for me it’s too much basic Linux staff so I decided to start on a higher logical level

Is this a question to me or an information?

I hoped, I can use my NAS in any case because it’s running 24h a day and I don’t have to support an additional system. If there is no chance yet, then I think, I would stop my HA approach and wait until I’m retired and start a new approach with new hardware and more time available :wink:


It is both information and a question as I am not 100% about that as a fact, but if remember correctly I believe that the current recommendion to not run Home Assistant docker directly under Synology DSM.

Personally I recommend either running Home Assistant OS in a VM (virtual machine) or on a dediclated computer and then then single-board-computers like Raspberry Pi 3/4 are good options.

That is why you want to run Home Assistant OS (which includes an appliance like operating system). Home Assistant OS makes installation and upgrades much easier (similar to Linux based appliances).

Tip is however to install (or once installed move) Home Assistant OS to some other attached storage than an SD-card. So best is to run Home Assistant OS from a SATA harddrive (internal or via USB).

FYI, just be aware that Home Assistant OS (HA operating system) used to be called “hassio” before.

You might want to checkout Home Assistant Blue if you want pre-configured hardware with HA installed

Home Assistant Blue is really just a ODROID-N2+ from Hardkernel with pre-configured hardware and Home Assistant OS pre-installed. If you consider all you get it does not cost that much more than a pre-configured Raspberry Pi 4 with external storage (which is also supported and works just as well).

Sonds good. Easy to use. Looks good. Fully supported.

Thanks for that hint :slight_smile:

Out of stock though so have to configure your own ODROID-N2+ or Raspberry Pi 3/4 inc. storage for it.

Tips is that there are many Raspberry Pi cases which include adapter and space for SATA harddrive.

I personally really like the look and style of the Argon ONE M.2 Case for Raspberry Pi 4

Raspberry Pi 3 and Raspberry Pi 4 are of course also fully supported by Home Assistant OS.

PS: If you want very powerful hardware and do not need GPIO then also take a look at Intel NUC.

I have seen, that it’s out of stock. I’m looking for a raspi4 Kit with all included incl. HDD. Your hint with the Argon case is good, maybe I use it as basis. Is there an easy way to install HA OS with not so many klicks on a bare Raspi?

I had a Raspi 2 and 3 a few years ago. Remember that there were regular issues with the SD card. Therefore HDD is preferred, hope that the Raspi 4 is ready to go with HDD without BIOS flash.

Hello Hedda,

a last post in this thread. A few minutes ago I ordered an Argon ONE M2. case with Raspi 4B/8GB plus power supply and M.2 SSD. I’m very excited and I hope this will satisfy my needs.

Thanks for your support.

Best Regards

Yes you basically only have to flash the image to the SD-card with BalenaEtcher or similar SD-flasher.

I’m not sure but I do not think that booting directly to USB is supported or stable yet on Raspberry Pi 4. The recommendation then is to boot to SD-Card and then only move the OS data partitions to the USB harddrive (think that might now even be possible from the Supervisor service in Home Asssistant OS).

Great hint, I’ll give you feedback when it runs. Actually I’m hoping, that the package will be delivered tomorrow :wink:

Hello Hedda,

it took a while until I got my equipment and also I needed two days until my brandnew Raspi boots HA OS from SSD.

Unfortunately I’m facing the same problem which I had starting this request two weeks ago: I can’t connect my CC2531 zu HA. It looks that it’s impossible with ZHA, so I will try with Zigbee2MQTT.

Maybee you have some hints whether this should go and how to integrate easily.

Best Regards


one last post: I sent my C2531 back and baught a ConBee USB hub which works well since I understood how to install. I started my first automations and I like HA.

Thanks for your hints and your patience with me.

Best Regards

Must be bad firmware. Did you not try your new ConBee USB stick with the ZHA integration at all then?

Also, make sure you upgraded to Hassos 5.11 first (as I read that there might be udev glitches in 5.10).

Should really be as easy as plug-and-play today as long as Zigbee coordinator has compatible firmware

Yes, I use the ConBee with ZHA. I tried the CC2531 with ZHA too, but it didn’t work. But I’m happy with the ConBee stick and also with my ONE M.2 case as well as with the SSD

1 Like

I can confirm that CC2531 is working nicely with ZHA. the stick is flashed with z-stack Zigbee 3.0 and everything work as it should even better than my Zonoff ZBridge with Tasmota.