Fire HD 10 (2019) has wrong resolution, Maybe?

Not sure where to start.

I noticed the other day that my Fire HD 10 (2019) which should have 1920px-by-1200px does not, well maybe. Using custom-layout-card, I set my layout to grid-layout and defined each section in pixels. When I do this what fits is 1280px-by-800px.

I have fully Kiosk Browser running and it reports screen size as 1920px1200px. I see no where to change the resolution in the Fire HD native OS and I do have wallpanel running but I don’t see a place to modify the resolution there. I have tried deleting wallpanel code but that didn’t change anything.

I am wondering if setting pixels in custom-layout-card is not equal to the actual resolution? Any other ideas?

title: Home
wallpanel:
  enabled: true
  enabled_on_tabs:
    - fire-tablet-home
  debug: false
  hide_toolbar: true
  hide_sidebar: true
  fullscreen: false
  idle_time: 150
  keep_screen_on_time: 86400
  black_screen_after_time: 7200
  control_reactivation_time: 1
  screensaver_stop_navigation_path: /dashboard-tablet/fire-tablet-home
  image_url: http://picsum.photos/${width}/${height}?random=${timestamp}
  image_fit: cover
  image_list_update_interval: 3600
  image_order: sorted
  image_excludes: []
  show_exif_info: false
  fetch_address_data: true
  exif_info_template: >-
    ${address.town|address.city!prefix=!suffix= //
    }${DateTimeOriginal!options=year:numeric,month:long}
  screensaver_entity: input_boolean.firescreensaver
  info_animation_duration_x: 30
  info_animation_duration_y: 11
  info_animation_timing_function_x: ease-in-out
  info_animation_timing_function_y: ease-in-out
  info_move_pattern: random
  info_move_interval: 0
  info_move_fade_duration: 2
  cards:
    - type: vertical-stack
      cards:
        - type: custom:weather-card
          details: true
          forecast: true
          hourly_forecast: false
          name: Bolton
          entity: weather.openweatherdaily
          current: true
views:
  - title: fire-tablet-home
    path: fire-tablet-home
    type: custom:grid-layout
    icon: mdi:home
    subview: false
    layout:
      max_cols: 3
      ### this works, any larger and the row on the right falls off the screen
      grid-template-columns: 550px 550px 180px 
      grid-template-rows: 78% 18%
      grid-gap: '-10px -20px'
      grid-template-areas: |
        "wcard alarm rnav1"
        "bnav1 bnav1 bnav1"
    cards: