Flamingo fa21rf (security1) tripping alarm in home assistant

Dear all,

I am migrating from Domoticz and I am quite impressed with the ease setting up the system in HA. However, one thing I cannot find on how to setup and I doubt that I am the first one with this problem. Still I cannot find the answer and therefore, post my question here.

In Domoticz I used my six Flamingo fa21rf smoke detectors also as a siren. As these are all coupled, sending the code through the rfxcom, I could let them all off. In HA however, I can only manage to have them as a sensor.

At the moment I have the sensor added in this way:

- platform: rfxtrx
  automatic_add: false
      name: Rook melders
      device_class: smoke
        seconds: 60
      fire_event: true

I also tried to put this block inside the switch definitions, however this did not work. Does anyone here have an idea to have these smoke detectors trip from HA?


I have the same 6 connected detectors and I want to do the same. But i want also a message, when they detect smoke.

With the switch option, I am not getting the signal, when the detectors are detecting smoke.
For this I am still looking for an solution.

My current situation:
I have used the switch option to trigger the smoke detector sirene from-out home assistant.
This is the code I used:

Switches RFlink


  • platform: rflink
    name: Rookmelder alarm
Einde Switches RFlink

How do you manage to get your device ID with the Flamingo FA21RF ?
I’ve tried :

  platform: rfxtrx
  automatic_add: true

But no new binary sensor appeared in HA state.



I have used a RFLink from:
It could send a message to the smoke detectors. But no battery, it was not that good for me.

I changed them for the heimann smoke detectors with Zigbee. They are working fine. It has a battery sensor and a binary sensor for the smoke. You can not trigger them to sound a alarm.