Flux light not working

My flux led is not being detected.

The error i see in the home-assistant log is this.

2018-09-13 16:21:05 ERROR (MainThread) [homeassistant.config] Invalid config for [light]: required key not provided @ data[‘platform’]. Got None. (See /config/configuration.yaml, line 78). Please check the docs at https://home-assistant.io/components/light/

here is my light configuration:
light:

  • platform: flux_led
    devices:
    10.0.0.62:
    name: flux_office_lights
    protocol: ‘ledenet’

I’m not sure if this is you’re problem, you might need to specify what kind of LEDs you have. In my yaml, I’ve included the “mode” option.

Example:

  • platform: flux_led
    devices:
    10.0.0.62:
    name: flux_office_lights
    protocol: ‘ledenet’
    mode: “rgb”

I tried that this morning. And it gives me the same error

Figured it out. I had my includes

I had this

light: !include lights.yaml

In my lights.yaml, i had light: at the top.
I removed this and everything worked properly…