Force frontend display timezone or sensor recording time instead of using local system time

Background:
Currently I’m abroad for work for a few months and located in a different timezone. My devices are set to GMT-4 and my home assistant instance to GMT+1. All graphs in the lovelace display + energy dashboard show the same time offset. I.e. the sensor locally recorded at 17:00 (GMT+1), is being displayed as 11:00 in the the frontend. This is especially annoying in the energy dashboard.

Request:
Request is an option to force the display/frontend timezone (or to actual time of the sensordata). It doesn’t make sense to have have solar production in the middle of the night :slight_smile: (see image).

If something is already available for this or anyone requires additional information, please let me know. Many thanks!