FosCam live video stopped working after 2022.5.2 upgrade

I upgraded Home Assistant for the fist time in around last 3 months and my foscams will not live stream and more.

I have the following error in the home assistant log

ERROR (stream_worker) [homeassistant.components.stream.stream.camera.garden] Error from stream worker: Error opening stream (ERRORTYPE_111, Connection refused) rtsp://:@:554/videoMain

port 88 used to be used.

I allowed port 554 on the f/w but no difference. I’m sure port 88 used to be used.

from pip3 the version are
home-assistant-frontend 20220504.0
homeassistant 2022.5.2

Kind Regards
Andrew

I have a work around, but not sure it is a fix

in the core.config_entries file
i changes the entries from

            {
                "entry_id": "a4f826ac4b58ee5073adad94aa42ed2a",
                "version": 2,
                "domain": "foscam",
                "title": "CanName",
                "data": {
                    "host": "CamAddr",
                    "port": 88,
                    "username": "Username",
                    "password": "Password",
                    "stream": "Main",
                    **"rtsp_port": 554**
                },
                "options": {},
                "pref_disable_new_entities": false,
                "pref_disable_polling": false,
                "source": "user",
                "unique_id": null,
                "disabled_by": null
            },

to

   {
                "entry_id": "a4f826ac4b58ee5073adad94aa42ed2a",
                "version": 2,
                "domain": "foscam",
                "title": "CanName",
                "data": {
                    "host": "CamAddr",
                    "port": 88,
                    "username": "Username",
                    "password": "Password",
                    "stream": "Main",
                    **"rtsp_port": 88**
                },
                "options": {},
                "pref_disable_new_entities": false,
                "pref_disable_polling": false,
                "source": "user",
                "unique_id": null,
                "disabled_by": null
            },
3 Likes

I can confirm that this works also, when using the graphical integration.
I have configured within my foscam FI9805W the port settings to a non standard port.
HTTP: 8009
and used this setting within the FOSCAM integration for the HTTP port and the RTSP port(has been default to 554).

This solved the problem not having a live stream in HA version 2022.12.1.
Thanks for the workaround!

Thanks @HAAndrewW. I been struggling with finding a fix for this issue and finally stumbled on your solution. Since my 3 Foscams were working previously using HTTP under 2022.21.1. I just made sure the HTTP port and the RTSP port were set to the same (i.e. port 80). I didn’t even need to go into the Foscam interface to change anything.

:grinning:

I’m having this issue too; but, I’m a total newbie.

I was hoping some kind soul could point me in the right direction as to how to edit the core.config_entries file.

I’m embarrassed to say: I’m a back end database developer with fairly extensive Linux experience and just can’t seem to find it. I’ve installed the File Editor and it’s just not there in the Home Assistant GUI. Never setup a RasPi before and I can’t seem to SSH into it.

To anyone who gets here after finding the same issue - and can’t find the core.config_entries file,

It is in the .storage directory - that’s why the file editor can’t see it - so use ssh to go to /config/.storage and you’ll se the file there.

I changed the RTSP port to the same as the port setting and it works fine now after a reboot