Fresh installation "Unable to connect to Home Assistant."


#1

Hello!

I wanted to try out home assistant but I cannot get it working. I tried to install it on multiple machines and multiple ways but always ended up with a problem I was not able to resolve or find any help online. Latest try was on raspbian, I was able to install it successfully and ended up on a login screen that will show “Unable to connect to Home Assistant.” after I have entered username and password. At the moment I’m experimenting with vbox using “hassos_ova-1.11.vmdk”. I’m experiencing the same problem. Any hints what can I try next? It cannot be a coincidence that I see the same message again.

Also, it would be very helpful if somebody can give me hint how can I enable samba or access bash? If I use “login” I get into “bin/ash” that I do not find very useful with my level of knowledge. Is there a way to get into bash?


#2

Which machine do you want to install HA on, and how do you want to install it?


#3

I have met the same question. Is your problem solved?


#4

gpbenton: Thank you for the reply! At the moment I would prefer to have it as a virtual machine; if I can choose then Oracle vbox.

myxu13 No it is not yet resolved. Do you maybe know what could cause the problem or can you share the link to possible solution?


#5

I have virtualbox virtual machines set up for both a manually installed virtual environment (which I use for testing) and the hassio vmdk install, so this is definitely possible. However, does your problem look like this? It might mean there is a general problem with the latest release.


#6

Yes, it looks exactly like that. I had a thought of the same thing, but assuming that a lot more people would complain about it. Can I maybe download vmdk from an older version from somewhere? At this point it should be enough for me to play around.


#7

There are a few older releases here, but I suspect they just install the latest version of HA on first start, which is what hassbian does.


#8

I have just tried an install into a virtual environment in a blank Ubuntu 18.04 vbox, and it all seems to work fine, so I’m not sure what you are seeing. Try these instructions


#9

Thank you so much for your help. As soon as I’ll catch some time I’ll try to install it on ubuntu.
Maybe I can also find some use of the hassbian images.


#10

Hassbian images can only be used directly on a raspberry pi. They can’t be used in a vbox.


#11

Hi guys! Thank again for the help. I was able to install it on latest ubuntu + python3.6. This should be enough to test it out and see how it works.

I think I can answer my previous question now as well. All is working fine if I try to access it only from localhost. For the remote I’m getting the same message. So I can assume it was working all the time but there are some security setting that I have to change. Anyway, will figure it out. Should be easy now when I have it working. (maybe that could be stated in the docs)


#13

Any luck uncovering the problem? I just did an upgrade and now I’m geting stuck at the same screen.


#14

Hey raff! How did you install it? How are you trying to access it?

Looks like I was not able to access it from the remote computer, only on the local machine using localhost:8123

You can try to run my docker container with docker-compose… It will take some time as it will compile it from source, but it will work. (running it on ubuntu)

Docker will map the port to your local machine so this should not be a problem I’m sure it is just a configuration problem.


#15

I did a fresh install of Hasbian on Orange Pi 3 using the directions here : https://www.home-assistant.io/docs/installation/hassbian/installation/. After waiting 20+ minutes for the install to finish I opened the interface using the ipaddress:8123 ffom my router, signed in on the opening page of the interface with
" You’re about to give http://192.168.1.105:8123/ access to your Home Assistant instance.

I tried logging in with Home Assistant Local

I put in my Username and Password which were accepted. Next to the page where “Loading Data” Appears. After the circling arrow disappears It says Unable to connect t Home Assistant. RETRY,

Many retry attempts attempts later I am still stuck at the same place. Attempts to SSH in are not successful therefore no access to the installation files, logs etc.

I have tried all the suggestions for this problem I have found on several sites. I tried to access HA on another PC on the same network.


#16

Hassbian was intended for a raspberry pi, so I have no idea if it works for an orange pi. If ssh login isn’t working, then I suspect it doesn’t. However, the one thing you have not tried is connect up a monitor and keyboard to the board and try to log on that way to see what is happening.

If there is nothing there, I suggest loading the normal operating system for an orange pi, and following the manual installation. The manual instructions for a raspberry pi should work, providing the OS is debian based