Fritz box call monitor

after latest update of fritzbox 7590 not work anymore the service call monitor.
any update?

Update of Home Assistant to 2021.2.3 or update of Fritzbox 7590 to FritzOS 7.25?

FritzOS 7.25

Please file a bug incl. log/debugging output at Github. FritzOS 7.25 is just starting to roll-out, more people will face this issue in the future.

image
image
my ip is 192.168.1.1 but when i put credential
image

http://download.avm.de/fritzbox/fritzbox-7590/other/fritz.os/info_en.txt

Please file a bug incl. log/debugging output at Github.

there is no error log. does not let me in with my account. the tcp port may have changed

The FritzOS has Create an New User (fritzxxxx) with 7.25, change this username to admin and give this user the correct password for the plugin. Restart your HomeAssistant and Try it again.

I tried using the fritzxxxx user created by the upgrade but this trial failes
This is the log

2021-04-01 16:33:27 ERROR (MainThread) [aiohttp.server] Error handling request
Traceback (most recent call last):
  File "/usr/local/lib/python3.8/site-packages/aiohttp/web_protocol.py", line 422, in _handle_request
    resp = await self._request_handler(request)
  File "/usr/local/lib/python3.8/site-packages/aiohttp/web_app.py", line 499, in _handle
    resp = await handler(request)
  File "/usr/local/lib/python3.8/site-packages/aiohttp/web_middlewares.py", line 119, in impl
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/security_filter.py", line 56, in security_filter_middleware
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/request_context.py", line 18, in request_context_middleware
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/ban.py", line 72, in ban_middleware
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/auth.py", line 129, in auth_middleware
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/view.py", line 129, in handle
    result = await result
  File "/usr/src/homeassistant/homeassistant/components/config/config_entries.py", line 150, in post
    return await super().post(request, flow_id)
  File "/usr/src/homeassistant/homeassistant/components/http/data_validator.py", line 60, in wrapper
    result = await method(view, request, *args, **kwargs)
  File "/usr/src/homeassistant/homeassistant/helpers/data_entry_flow.py", line 106, in post
    result = await self._flow_mgr.async_configure(flow_id, data)
  File "/usr/src/homeassistant/homeassistant/data_entry_flow.py", line 158, in async_configure
    result = await self._async_handle_step(flow, cur_step["step_id"], user_input)
  File "/usr/src/homeassistant/homeassistant/data_entry_flow.py", line 216, in _async_handle_step
    result: Dict = await getattr(flow, method)(user_input)
  File "/usr/src/homeassistant/homeassistant/components/fritzbox_callmonitor/config_flow.py", line 169, in async_step_user
    self._phonebook_id = user_input[CONF_PHONEBOOK]
KeyError: 'phonebook'

I solved the problem removing following entry from configuration.yaml

- platform: fritzbox_callmonitor
    name: Phone
    username: admin
    password: XXXXXXX
    host: 192.168.1.1

Hi, I had the same issue and figured out, that the rights as described in the integration are no longer satisfactory for the call monitor. I set the right to maximum level and tried, if the monitor is still/again working. And it does! So my finding is, that either AVM changed some of their internal rights or the API is no longer valid to really read the port#1012.
I changed the rights, for the moment to FritzBox “admin” and it works.