Frontend Overview Does Not Always Display All Cards/Components

Whenever I browse to the Overview section in the Web UI, auto-discovered components as well as some elements related to devices I’ve hardcoded into my configuration.yaml don’t always appear. To clarify:

  • Everything that I’ve hardcoded in my configuration.yaml always shows up. However, for example, in the case of my Amcrest IP Camera, while the ‘Switch’ group always appears in Overview, the actual video feed may or may not appear on any given page refresh.

  • I have a few Google devices (Mini and 2 chromecasts) that were auto-discovered (and I activated the integration). Nothing about them is hardcoded in my configuration.yaml. Sometimes they show up in Overview, sometimes they don’t on any given page refresh.

Here’s my configuration.yaml for reference -

homeassistant:
  # Name of the location where Home Assistant is running
  name: Home
  # Location required to calculate the time the sun rises and sets
  latitude: 0
  longitude: 0
  # Impacts weather/sunrise data (altitude above sea level in meters)
  elevation: 0
  # metric for Metric, imperial for Imperial
  unit_system: metric
  # Pick yours from here: 
  time_zone: UTC
  # Customization file
  customize: !include customize.yaml

# Show links to resources in log and frontend
#introduction:

# Enables the frontend
frontend:

# Enables configuration UI
config:

# Uncomment this if you are using SSL/TLS, running in Docker container, etc.

# Checks for available updates
# Note: This component will send some information about your system to
# the developers to assist with development of Home Assistant.
# For more information, please see:
  # Optional, allows Home Assistant developers to focus on popular components.
  # include_used_components: true

# Discover some devices automatically
discovery:

# Allows you to issue voice commands from the frontend in enabled browsers
conversation:

# Enables support for tracking state changes over time
history:

# View all events in a logbook
logbook:

# Enables a map showing the location of tracked devices
map:

# Track the sun
sun:

# Sensors
sensor:
  # Weather prediction
  - platform: yr
  - platform: amcrest

# Text to speech
tts:
  - platform: google

# Cloud
cloud:

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml

panel_iframe:
  configurator:
    title: Configurator
    icon: mdi:wrench
    url: http://192.168.2.61:3218
    
amcrest:
  - host: 192.168.2.67
    username: admin
    password: Unsecure321!
    sensors:
      - motion_detector
      - sdcard
    switches:
      - motion_detection
      - motion_recording

I tried commenting out discovery: in my configuration.yaml, but that didn’t really seem to make a difference. There aren’t any errors in the logs either. I’m on HomeAssistant 0.84.6 (running Hass.io docker container and associated containers via hassio_install script).

Has anyone encountered this behavior? Any ideas on how to ensure everything always shows up in Overview? (Hardcoding every single device doesn’t seem to be a silver bullet since I did that with the Amcrest IP Cam and the video feed aspect of that component doesn’t always show up).

Other than discovered components sometimes taking a while to show up on hass starting, I have not seen this.

Quick Update: This only happens with Google Chrome. Firefox works just fine (everything stays on Overview even after multiple page refreshes).

I hope this info can help devs. If I can help diagnose, please let me know.

I have issues with icons not always rendering in chrome - never tried in firefox - i’ve put it down to memory issues somewhere