Fully Kiosk on older Kindle Fire

I’m trying to install Fully Kiosk on an old Kindle Fire I found packed away. First time working with FKB. The Kindle is model D01400 and appears to run a customized version of Android 2.3. In the Google Play Store, it says FKB is not compatible with the device. Does anyone know of a way to install FKB?

If you go to their website you can download the apk directly.