Fyrtur state not updating in HA

Tags: #<Tag:0x00007f73ae244f68>

I have had 3 of the Fyrtur blinds for a couple fo weeks now and the last 2-3 weeks the state of the blinds is not updated in HA. I can control the blinds and set the current position but HA always has the state to 100%.
I cant find any logs related to the problem…

HA version 101.3
Deconz HassIO addon v3.7.

If i set the blind state with the slider:

If i reload the page:

State (current position) is not updated:

I have tried to unpair and pair the cover several times…

I found that (GITHUB) Fyrtur Ikea blinds not working properly #27461 had the same issue with the Trådfri integration.

Anyone that has the same problem?

I have the same issue… i removed them and will wait for it to get fixed.

HA 103.5 and deCONZ addon 5.0

I had the same issue but somehow it is working correctly now. The only thing i did was pushing a button on the blind itself after pairing and somehow now the state is reported corrctly. I’ve made a template sensor to show the current_position:

- platform: template
      value_template: '{{ states.cover.blind_sleepingroom.attributes.current_position }}'
      friendly_name: 'Current Position'
      unit_of_measurement: "%"
      icon_template: >-
        {% if states('sensor.blind_sleepingroom_open_percent') | int < 50 %}
        {% else %}
        {% endif %}

Hi Jones! I have the same issue and wonder if you can elaborate on your solution?

  • what button did you push?
  • is the position updated correctly in the normal HA interface (as in the print screen above)?


I just did a single push on the down button to check if the blind is working correctly. The state works fine right now an the template sensor works as expected.

One question: Have you set a maximum length for the blind?

HA version 104 has fixed it for me

Is anyone of you good at appdaemon? I’d like to have an app for the blinds remote. I can currently fetch the deconz events with this app:

import appdaemon.plugins.hass.hassapi as hass

class RolloRemote(hass.Hass):

    def initialize(self):
        if 'event' in self.args:
            self.listen_event(self.handle_event, self.args['event'])

    def handle_event(self, event_name, data, kwargs):
        if data['id'] == self.args['id']:
            if data['event'] == 1002:
                self.log('Single Press Up')
                self.call_service("cover/open_cover", entity_id = self.args['rollo'])
            elif data['event'] == 2002:
                self.log('Single Press Down')
                self.call_service("cover/close_cover", entity_id = self.args['rollo'])
            elif data['event'] == 1003:
                self.log('Long Press Up')
                self.call_service("cover/open_cover", entity_id = self.args['rollo'])
            elif data['event'] == 2003:
                self.log('Long Press Down')
                self.call_service("cover/close_cover", entity_id = self.args['rollo'])

Whenever a button on the remote is pressed or long presse the blinds either go up or down. I’d like to have the original function of the remote that when you press on the opposite direction the blind stops at the current position. Can anyone help out?

okay! Yes I have the max length set through the normal IKEA procedure. tried updating to 104.0 now and also pressed the down button, nothing helps. Im runnig HA in docker with the martoc deconz docker (2.05.71). Do you have any more ideas?

Thank you!

Sorry, no idea. I’m running hass.io in esxi and have the official deconz addon. Everything works fine in 0.104.

I seem to have this problem again, since about 1-2 days ago. The state doesnt update in HA for Fyrtur blinds.

Anyone else? or just me?

I am having the same issue now, I bought the blind a month ago and it was working fine until last week, but last week it stopped sending its position back to HA. I can move it to any position from HA but the blind is not sending any data back so HA doesn’t know the current position or battery or linkquality. When the blind was working fine I could see all the data it was sending to HA while it was moving in Zigbee2mqtt, but now there is no data at all even when the blind is moving

Same problem here, any solutions ?

I have similar problem. Installed two blinds, aside from the saga of Deconz detecting them then them disappearing from Deconz… I now have two blinds in Homeassistant, one which reports accurate status, and one that does not. Tried deleting it from Deconz, then it cannot be re-added, only via VNC.

Just tried the solution posted here:

It seems to have worked and now the status is being reported…