GE 14294 Dimmer brightness issue

Hello all,

I’ve been adding different switches and sensors to my Hassio setup via Z-stick, and they’ve all had their strange settings, and I’ve been able to configure most of them, with loads of help from this community (thank you!)
These dimmers, however, seem to be stumping me.
In addition to showing up as “lights” instead of switches, their brightness has been an issue.
I had seen previous posts about them, and have adjusted the polling, and dim steps and rates, but it seems there are only two brightness levels they will come on at: previous brightness, or 8/255.
If I simply call for them to turn on, they will turn on at previous brightness.
But if i explicitly set the brightness in an automation, to “brightness: 100” for example, the lights come on at 8, and after several minutes MIGHT increase to, say, 42, but that’s it.

If anyone has insight into this issue, I would greatly appreciate the help!

You probably don’t need polling, but you do need to set refresh_value and delay. I use the following with my GE Z-Wave dimmers:

zwave:
  ...
  device_config:
    light.family_room_lamp:
      refresh_value: true
      delay: 3
  ...
1 Like

I do have that setup, sorry I had meant to mention that.
I think I figured out what the issue was.
I had restarted Hassio many times while trying to get this to work, but it seems the brightness setting wouldn’t change until after I reloaded the automations instead of restarting.
It is worth mentioning that this was not an issue with any of the 10 GE On/Off paddles I have, only the dimmers.