GE Z-Wave Dimmers Broken

Tags: #<Tag:0x00007f7398577778>

I don’t have device_config settings or customizations set for my GE dimmer. It still works with 1.05.2

Working fine for me on 105.2… same basic workaround for the jasco polling as you:

  device_config:
    # GE/Jasco dimmers don't self report state so rely on zwave polling.
    # The result is an incorrect state shown in HA when turning on/off from HA.
    # A 2sec delay before polling allows enough time for dimmer to transition
    # before HA gets the new state.
    light.backyard_lights:
      refresh_value: true
      delay: 2

I’m using 2sec because with my sorta slower dim rate, it sometimes takes 2sec for a command to finish up. Is it possible you might have changed dimming rate to where 1sec is no longer enough and you need 2 now (or even longer… for example mine probably should be 3, since calculating out steps and step rate it could take mine 2.3sec)?

Thanks, I’ll try to mess around with the delay tomorrow.

I even commented all of this device_config out as well hoping it would not be needed since HA stopped working with the dimming and it’s the same behavior.

What model numbers are you using? Are they Z-Wave Plus?

FWIW, here is what I use:

light.family_room_lamp:
  refresh_value: true
  delay: 4
  polling_intensity: 1
light.master_bedroom_lamp:
  refresh_value: true
  delay: 4

light.family_room_lamp is a model 12718 Plug-In Smart Dimmer, which is not Z-Wave Plus. I found I need both refresh and polling with this device.

light.master_bedroom_lamp is a model 28167 Plug-In Smart Dimmer, which is Z-Wave Plus. I found I only need refresh with this device.

Note that the delay is set to 4 (seconds) for both because their default turn on/off transition time is around 3 seconds.

1 Like

No luck.

The kitchen light is: “Jasco Products 14294 In-Wall Smart Dimmer”

No issues on my end. I use refresh_value: true and delay of 3. I’m on 105.2. Voice works, dimming works, on off works.

How good is your Z-Wave mesh network? I.e., how many Z-Wave devices do you have, are they in reasonable proximity of each other, etc.?

Have you healed the network recently?

Sorry for the “is it plugged in” type question, but I started wondering. Not sure why else you’d have these problems when others don’t. Just a thought…

I have about 10 Z-Wave devices all within 20-30 feet of the controller. I only have issues with the wall dimmers (lights turn on and off, just no dimming). All Z-Wave devices are GE and are Z-Wave Plus.

GE wall dimmers are not my favorite at the moment. I’ve got a batch of innoveli’s coming in, interested to see if they work any better. As for the no-dimming, are they dimming on the hardware themselves? If not, that has nothing to do with home assistant.

GE is solid with all my other devices, just never had the dimmers working great. Prior to HA .105 though, I had them working pretty well with the delay, polling, and refresh. Might try to go back to a version prior to see If i still have the issue there.

The slider is wroking and dimming in HA, but the devices don’t dim. If turn the light off and on then it turns on at the dimmed setting I have it on in HA.

So the devices work on your hardware though. I phrased that poorly. The dimmers work when you physically adjust them at the light switch, correct?

EDIT: I just tested one of mine and they work via HA and the physical light switch.

That is the way lights are intended to work… when you turn one ‘on’, it will go to the last brightness setting. If you want a button to turn them to 255, you can do that with an input boolean and an automation. There are probably better ways but that is off the top of my head.

Think you missed this bit, which is odd:

Correct, no issues using the physical switch.

Did you adjust any settings in the zwave configuration, or are they ‘out of the box’? It just seems odd that you have different behavior

Only changed the name of the zwave device and switch name device. I also added a light entity from the switch, which I also did with my other switch lights.

I tried HA .104.3 and the same issue. I did lose power a couple days ago (right about when I also upgraded to .105 and maybe the power outage is messing with my dimmer switches? I’ll try removing and reading them tomorrow to see if that makes a difference.

I’ve had 3/30 jasco devices die. Part of the reason why I’m making the switch. Seems like the old units had a shelf life of 3 years. Power outages killed 2 of the 3.

Let us know how you like the Innoveli’s. GE switches also are the bulk of my inventory as well.

Yah, They should arrive today. I’m pretty sure the zwave setup for home assistant is way more involved. These devices require v1.6 of OZW and HA is on 1.4. So you have to do some config shuffling. I have a breakdown of what’s expected. I’ll update the post on how ‘hard it is’. I’m really interested in how the dimmer behaves in the UI. I do not like the GE interaction at all. The look is also wildly different. It has this LED that (I think) displays the current brightness level. Either way, I’m excited for it. Also, my order came with 2 free RGB light bulbs… so that was a bonus.

1 Like

No go, got the same issue. Wish I could figure out if it really was the .105 update or my power outage. Everything was working out perfect with these dimmers for the most part until then :frowning:

When dimming the physical switches they actually update in HA, but not the other way around; it’s like HA can’t control the dimming only.