GE Zwave Toggle switch loses tracking of status

Hi all,

I have a GE zwave plus toggle switch in my bathroom that interfaces with my aeotec usb stick gen 5. It works great for a while and then hassio no longer tracks its on/off status. The only fix I can find is removing it from my zwave stick and then adding it back. This fixes it for a month maybe and needs to be repeated. I haven’t found anything through my googlefu that would point to a fix. Was curious if anyone can point me in a direction to figure out why this happens and how to fix it. Thanks!

bump please

How many zwave devices do you have?
How far from the stick is this device?
Have you tried the zwave map to get an overview of your zwave mesh?

I have about 7 devices or so, all within 80 feet of the stick, which is on an extension cable away from my server. This one isn’t any further than a motion sensor which works fine. I can also control the device fine from the frontend, it’s just not updating if the switch is toggled manually.

I have not tried the zwave map yet.

going to try and bump again

Do you have polling enabled for this switch?

Is it a model 12727 or 14292, or something else?

What is your Z-wave configuration?

It’s a model 14291. I don’t see anything in the zwave configurator that allows polling specifically for that switch. In my config.yaml this is what I Have for Z-wave

  usb_path: /dev/ttyACM0

Ok, that’s the paddle version of the 14292 model that I have (which is the toggle version.) I believe these function identically. And, FWIW, I’ve never had these issues with this switch, nor have I had to enable polling for it. (The older, non Z-wave Plus models are a different story, though.) However, maybe polling will help in your scenario…

To enable polling you need to make two changes (I believe. At least this is what I did.)

First, you need to add the following under zwave: in config.yaml:

  polling_interval: 10000
  device_config: !include zwave_device_config.yaml

Then restart HA.

Second, go to the Configuration → Z-Wave page. Then select the switch under “Z-Wave Node Management.” Then click on “Entities of this node” and pick the entity. At this point “Polling intensity” should appear. Change the value from 0 to 1 and then click SAVE.

These changes should cause this switch to be polled every 10 seconds. If you want to adjust the period change polling_interval (which is in msec) and/or “Polling intensity” (which controls how many polling cycles should occur before the device is polled. 1 means every cycle, 2 means every other cycle, etc.)

Hmm, it just occurred to me. I wonder if your network needs to be healed. Have you tried that? Maybe the nodes of your network don’t know about each other, causing communications from the hub to this switch to be less than optimal. Before enabling polling, maybe heal the network: Configuration → Z-Wave → HEAL NETWORK.

Thanks for the suggestions. I’m going to try the polling and see if that helps. The weird thing is that when the device is first included, it works for a while and then stops, which I’m not sure if polling will help, but I am willing to try anything at this point!

Healing my network I have avoided doing for a different reason. In particular with this jasco switch and the motion sensor one, after a healed network, it would for some reason form associations with my motion sensors. Which would basically turn the light on when the motion sensor gets triggered and off when the motion sensor detects no motion, even with hassio off. It was some weird Zwave thing. I might try that again later but the apartment is small and the stick is off my server with a 3’ usb cord. So I don’t think it’s a distance issue. I will try polling and see what happens.

You should not avoid healing the network because of association issues. Z-Wave is a mesh network, which means to work properly each node needs to know what other nodes are in range of it. Once that information is correct it helps to make sure messages get through. If that information is old, and worse, incorrect, it can really mess things up. I strongly recommend healing. Then handle the association issue separately. (In theory you should be able to see and remove associations from HA’s Z-Wave Configuration page.) If you can’t get that worked out, maybe it would be worth removing both of those nodes from the network, then factory resetting them (so they lose any pairing and associations), then add them again.

Adding polling might actually make matters worse, because it will cause more network traffic. And if messages aren’t getting properly routed, adding more traffic just might make matters worse.

I don’t claim to be a Z-Wave “expert.” These recommendations are based on good old “Googling” and experience.

Oh, I should maybe mention, I did have some (seemingly similar) issues with one of my older GE/Jasco Z-Wave switches. A model 12727. I ended up physically disconnecting it from the electrical wires and re-hooking it up. Nothing I tried (removing/adding, factory reset, polling, etc.) seemed to help prevent it from “going quiet” from time-to-time until I did that. I guess that’s the equivalent of restarting Windows! :laughing:

So the polling seems to have fixed the issue at the moment! Thanks for the tip.

1 Like