Generic-bk7231n-qfn32-tuya WRGB light incorrect colour on bootup

I have hacked a Costco set of lights to move from Tuya to ESPHome.
This works great, but I get a weird bug… when the device is first turned on the colour is bright white even when turned off.
Then when I turn to a colour the white lights are still on, so greens look very pale.
Finally if I change (via HA) the lights to White and then back to RGB, it fixes it.
I am looking at a way to do this using the on_boot process… The current logic below does not work & I don’t know enough about ESPHome to know why its doing it & how to fix it.

esphome:
  name: ivysleds
  friendly_name: IvysLEDs
  comment: Ivy's LED Lights
  on_boot:
    priority: 600.0
    then:
      - light.turn_on:
          id: light_rgbw
          brightness: 100%
          white: 100%
      - delay: 5 seconds
      - light.turn_on:
          id: light_rgbw
          red: 0%
          green: 100%
          blue: 0%
      - delay: 5 seconds
      - light.turn_off: light_rgbw

bk72xx:
  board: generic-bk7231n-qfn32-tuya

# Enable logging
logger:

mdns:

# Enable Home Assistant API
api:
  encryption:
    key: ""

ota:
  - platform: esphome
    password: ""

wifi:
  ssid: !secret wifi_ssid
  password: !secret wifi_password

  # Enable fallback hotspot (captive portal) in case wifi connection fails
  ap:
    ssid: "Fallback Hotspot"
    password: ""

captive_portal:

text_sensor:
  - platform: libretiny
    version:
      name: LibreTiny Version

output:
  - platform: libretiny_pwm
    id: output_red
    pin: P9
  - platform: libretiny_pwm
    id: output_green
    pin: P8
  - platform: libretiny_pwm
    id: output_blue
    pin: P7
  - platform: libretiny_pwm
    id: output_cold
    pin: P6

light:
  - platform: rgbw
    id: light_rgbw
    name: Light
    red: output_red
    green: output_green
    blue: output_blue
    white: output_cold
    color_interlock: true
    default_transition_length: 0.25s
    effects:
      - pulse:
          name: "Fast Pulse"
          transition_length: 0.5s
          update_interval: 0.5s
          min_brightness: 0%
          max_brightness: 100%
      - pulse:
          name: "Slow Pulse"
          # transition_length: 1s      
          # defaults to 1s
          update_interval: 2s
      - pulse:
          name: "Asymmetrical Pulse"
          transition_length:
            on_length: 1s
            off_length: 500ms
          update_interval: 1.5s
      - random:
          name: Random Effect With Custom Values
          transition_length: 5s
          update_interval: 7s

Am I missing something?

As I say if I Change in HA to white and then to RGB it works fine… it is just on that first boot… which is a little annoying as ideally it would remember that my daughter likes it full green :smiley: