Getting Response 500 Error With Every Automation

Hello. I cannot get automations to work AT ALL! Every one that I try gives me the same error in my log, and I know I’m doing the automation codes themselves correctly. Even the automations that Home Assistant provides won’t work and give this error. It gives me a response 500 error.

TypeError: 'NodeStrClass' object does not support item assignment

If someone could help I’d greatly appreciate it!

Can you share the full log and your automations.yaml file. Direct message me if you think either contains sensitive information.

Can you explain the steps you are taking to “try” an automation?

Here’s the automations.yaml file:

automation:
  - id: this_is_the_automation_id
    alias: "The optional automation alias"
    trigger:
      - platform: event
        event_type: ifttt_webhook_received
        event_data:
          action: call_service  # the same action 'name' you used in the Body section of the IFTTT recipe
    condition: []
    action:
      - service: "{{ trigger.event.data.service }}"  # replace with the service you want to call
        data:
          entity_id: "{{ trigger.event.data.entity_id }}"

Here’s the error log:

Logger: aiohttp.server
Source: /usr/local/lib/python3.12/site-packages/aiohttp/web_protocol.py:421
Error handling request
Traceback (most recent call last):
  File "/usr/local/lib/python3.12/site-packages/aiohttp/web_protocol.py", line 452, in _handle_request
    resp = await request_handler(request)
           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.12/site-packages/aiohttp/web_app.py", line 543, in _handle
    resp = await handler(request)
           ^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.12/site-packages/aiohttp/web_middlewares.py", line 114, in impl
    return await handler(request)
           ^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/src/homeassistant/homeassistant/components/http/security_filter.py", line 92, in security_filter_middleware
    return await handler(request)
           ^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/src/homeassistant/homeassistant/components/http/forwarded.py", line 83, in forwarded_middleware
    return await handler(request)
           ^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/src/homeassistant/homeassistant/components/http/request_context.py", line 26, in request_context_middleware
    return await handler(request)
           ^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/src/homeassistant/homeassistant/components/http/ban.py", line 85, in ban_middleware
    return await handler(request)
           ^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/src/homeassistant/homeassistant/components/http/auth.py", line 242, in auth_middleware
    return await handler(request)
           ^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/src/homeassistant/homeassistant/components/http/headers.py", line 32, in headers_middleware
    response = await handler(request)
               ^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/src/homeassistant/homeassistant/helpers/http.py", line 73, in handle
    result = await handler(request, **request.match_info)
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/src/homeassistant/homeassistant/components/http/decorators.py", line 81, in with_admin
    return await func(self, request, *args, **kwargs)
           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/src/homeassistant/homeassistant/components/config/view.py", line 125, in post
    self._write_value(hass, current, config_key, data)
  File "/usr/src/homeassistant/homeassistant/components/config/automation.py", line 84, in _write_value
    cur_value[CONF_ID] = uuid.uuid4().hex
    ~~~~~~~~~^^^^^^^^^
TypeError: 'NodeStrClass' object does not support item assignment

Thanks!

I’m going into home assistant, going to automations, pressing new automation, and using the drop downs to select what the triggers and actions should be. Then I get this response 500 error.

1 Like

Nevermind, I figured it out. Thanks everyone!

Any hints for future users with the same problem?

1 Like

I just cleared the automations.yaml file of all text and went into home assistant and pressed new automation and it worked.

1 Like