Glances integration on v.0.101.3 (no connection to host)

Hi helping brains out there,

I’ve installed the glances add-on from the repository, linked it to influx, grafana is showing results, everything fine so far.

Now sensors:
according to https://www.home-assistant.io/integrations/glances/ my configuration.yaml file has this entry:

# glances
glances:
  - host: localhost

restart of HA, notification that new devices were discovered, Glances.

config screen

what would be username and / or password?

If I don’t do any more or any configuration I get this message:

Verbindung zum Host nicht möglich (no connection to host)

:confused:

what did I do wrong?

Here is the glances config from HA

{
  "log_level": "info",
  "process_info": false,
  "refresh_time": 10,
  "ssl": true,
  "certfile": "fullchain.pem",
  "keyfile": "privkey.pem",
  "influxdb": {
    "enabled": true,
    "host": "a0d7b954-influxdb",
    "port": 8086,
    "username": "glances",
    "password": "somepassword",
    "database": "glances",
    "prefix": "localhost",
    "interval": 60
  }
}

Thanks upfront
Ralf

I assume you activated ingress for glancess add-on. try that address as for the host name.

or what is the address when you click OPEN WEB GUI? you can use that as well. whatever takes you to do glances web interface

Your username and password are in your config

"username": "glances"
"password": "somepassword"

At first I also though so but I think these are the user/pass for posting glances data to influxdb.

Wait, you added it from the add-on repository so follow the instructions form it. It says on the bottom to do it like this and that the port 61209 is import as that is how it is setup.
You have the wrong port in the Integration.

sensor:
  - platform: glances
    host: 127.0.0.1
    port: 61209
    version: 3
    resources:
      - 'processor_load'
      - 'memory_use_percent'
      - 'disk_use_percent'
1 Like

Thanks sleeepy2. That did the trick.