Google assistant Hassio login screen loop

Tags: #<Tag:0x00007fa7401f3440>

Hi Peeps

I have just over come my duck dns external visibility to hit another wall

I have followed the manual steps to setup google assistant to work with hassio (from the hassio component page)

When trying to add my test app as a device through the Home app, it displays the login screen but once i type in my details it loops me back to the login screen

I have tried to purposefully login with the wrong details to test and it provides the standard invalid login message, and does not loop back

anyone had a similar issue or has clue as to where i went wrong

I am using a Pi3

is the port forwarded on your router? I have only seen Google Assistant do this when it can’t connect to HA. Happened to me when my duckdns script updated my IPv6 IP address to the wrong IP address…

Hi David! Yebo my ports are, I’m using 443 to 8123, I am able to connect to my HA outside of my network.

I see you mentioned ipv6, have you configured your google actions project with the ipv6 IP address or did you use your domain? I followed the instructions twice via two different google projects but same result, if I put the incorrect password it gives me the standard hassio incorrect username or password message so I reckon it connecting to my pi - iv only come across one other post with this issue, I think you helped the guy out he had to remove some rules he had originally added for port forwarding - besides some that I have setup for gaming devices, there is only one rule for the pi, the 443 to 8123

did you specify the port in the URL you entered at Google? I am using my duckdns domain.

Yebo! I have, I used the 443 in the duck dns domain address

Are you using a reverse proxy? If so, did you enable websockets?

Negetive no proxies, I did a quick screen recording and for a split second before it returns to login screen in tiny writing it says account linked and then goes back to login screen like nothing happened

you can resolve it reinstalling google home on your phone.

Unfortunately no such luck, my guess it is something to do with my config…I wonder if the location set in the hassio could impact it, given google home isn’t supported in country yet, anything special needed for the hassio config file besides exposed domains and project ID?

Did you ever get to the bottom of this having exactly the same problem?

Unfortunately not, iv gone through the steps 4 times, I’m almost at the point where I’m going to rather just pay for hassio cloud

I wonder why our config is so different? I’m not using duck DNS I am using my own custom DNS but I am using let’s encrypt. I’m only forwarding 443 to 8123 and 80 to 80 for let’s encrypt renewal. External access works fine, it flashes up the link message and redirects straight away. My Google assistant config is minimal at the moment. I did find a similar problem with someone complaining that exposed by default parameter caused problems by not exposing any entities. I’m sure it’s a configuration.yaml problem…

Right sorted it…for me anyway, it’s even there in the guide. If you have hassio shortcut on your home screen (android) it stops the redirection from Hass to Google…not entirely sure why but I removed it and now it works ok…hope it works for you!

I had a similar problem. But only factory reset of the phone helped me.