Google Assistant Nabu Casa wrong base_url


Severall times I got the message: unable to contact HA cloud by Nabu Casa from my Google Assistant.
When I check my logger, I see the wrong base_url:

{'handler': 'google_actions',
 'msgid': '30877bc960f6fec9c79027ef6e3e9a54',
 'payload': {'inputs': [{'context': {'locale_country': 'US',
                                     'locale_language': 'en'},
                         'intent': 'action.devices.EXECUTE',
                         'payload': {'commands': [{'devices': [{'customData': {'baseUrl': '',
                                                                               'httpPort': 8312,
                                                                               'httpSSL': True,
                                                                               'proxyDeviceId': 'dc239320-8099-45ca-ac08-8364b1751d1d',
                                                                               'uuid': '56381b1bed8641fdb6abb82c175fc4a6',
                                                                               'webhookId': '8946dbb84df0a434c4d036f04d9023d92e8b37389d18bb346568c793c3d58717'},
                                                                'id': 'light.light1'}],
                                                   'execution': [{'command': 'action.devices.commands.OnOff',
                                                                  'params': {'on': False}}]}]}}],
             'requestId': '12979877797385980720'}}

I didn’t set a base_url in my config or something… How to fix this?

Hi @mirkin1993, welcome to the community!

What do you have configured for external and internal when you go to Configuration > General in the UI? You have to have advanced mode enabled for your user to see those options.

Nothing, both are empty

Try adding https://your_nabu_casa_url for external and http://your_local_HA_ip:8123 for internal.
Note, one is https and the other is http


Restart HA after that and see if the behavior changes.