Google Cast Integration cant find devices anymore

Setup: Hassio on Oracle VM running on Windows 10
Core V: 0.118.5
Bridged network adapter.

I’ve had the Cast integration up and running for months and it has been populated with my devices.
I bought a Nest Hub and installed it on Nov 30.
I remember seeing that Nest Hub in my Cast list before I tried the ol’ “remove and add” to fix it not working.

So something happend in the background from Nov 30 to today when Google Cast isn’t finding my devices anymore.

  • My HA setup does have Google Assistant integrated, so from Google Home I can controll everything
    I’ve exposed from HA.
  • I have not made any changes in my router config prior to finding out Cast stopped working
  • The only big changes I have made beyond adding some lovelace components is
    to install mini-graph-card and utilize it in LoveLace, aswell as follow the regular Core updates to HA.

What I’ve tried:

  • Fiddling with my Asus AC68U router settings in all regards to make sure mDNS is working properly, but most settings I could find were as they should be
  • I’ve tried removing mini-graph-card
  • I’ve tried downgrading Core 0.118.5 to 0.118.4 and to 0.118.0

None of the above mentioned tries yielded any success.
Through some google searches I found a way to enable some deeper logging of the cast component
however this does not seem to populate my logs any more than before.

# Provide diagnostic information
  default: info
    homeassistant.components.generic: debug
    pychromecast: debug
    pychromecast.discovery: debug
    pychromecast.socket_client: debug

So I’m lost now, do not know what else to try…
All my other devices, phones, pcs can see my cast devices and cast to them.
I can even cast my views from HA Cast app… so It’s just HA that cant see my devices anymore.
heeeelp :slight_smile:

Glad I’m not the only one seeing this, but no idea how to troubleshoot further. I know Google made some changes recently as I had to update my Onkyo receiver with new firmware to update Chromecast built-in version to 1.44

This firmware was released from Onkyo on 12/22 and now Google Home see’s my Onkyo receiver as being a cast device again.

So at this point I’m think there is something broken with the existing integration.

Did you guys ever find a solution ?