Google Cloud TTS and Sonos: UPnP Error 714 received

Hey there,

I am trying to configure Google Cloud TTS according to the Google Cloud integration docs. Everything went fine - until I try to actually make it say something - then HomeAssistant will just give me an error:

UPnP Error 714 received: Illegal MIME-Type

Am I doing something wrong? My TTS config looks like the following:

tts:
  - platform: google_cloud
    service_name: cloud_say
    key_file: integrations/googlecloud.json
    cache: true
    cache_dir: /tmp/tts
    time_memory: 300
    language: de-DE
    gender: female
    voice: de-DE-Standard-F
    encoding: linear16
    # speed: 0.9
    # pitch: -2.5
    # gain: -5.0
    profiles:
      - small-bluetooth-speaker-class-device

The logs in HomeAssistant are stating the following:

2022-07-09 17:39:36 ERROR (MainThread) [homeassistant.components.websocket_api.http.connection] [547846749824] Error handling message: Error calling SonosMediaPlayerEntity.play_media on media_player.device: UPnP Error 714 received: Illegal MIME-Type from 192.168.1.28 (unknown_error)

And this is the service I tried to start:

service: tts.cloud_say
data:
  entity_id: media_player.device
  message: Test

Any help appreciated - thank you so much!

Matthias

I had the same error and I was able to solve it by using: encoding: mp3