Google Home can no longer adjust volume of media player?

I’ve exposed my Marantz SR5011 to Google Home via the Nabu Casa cloud and it has been working just fine up until recently. The Home app used to see the amplifier as a dimmable light and I could issue voice commands to Google Home to adjust the amplifier to a certain percentage. Awesome.

Now the amplifier just shows up as a light, no dim effect available. Pretty crap.

I’ve tried to remove it and add it back to Google Home, but it’s all the same. Just a power button. No slider to adjust volume/brightness.

I’m not sure exactly which version that broke this, but it must have been around 0.93.

Is there any way to force it to show up as a dimmable light for Google? I’ve tried reading around, but can’t find any way to do that.

Same issue here with a Denon AVR-X4300H. Tried unlinking and relinking in Google Home but that didn’t seem to make a difference.

1 Like

Posted a bug report here:

No problem here with my Denon, indeed something changed a few weeks ago in 92, Media player is now exposed as a volume threat instead of a light… It’s working for me

1 Like

Issue the command to Google “sync my devices”.

Yea, you need to do that too, but it doesn’t help. Still shows as a regular light without dimming.

And what happens when you tell google to adjust the volume?
If I tell google “Set the receiver to 90%” it sets it just fine. Give it a shot.

1 Like

Well, my Denon AVR X4000 is still exposes as a Switch to Google Assistant. But I am still able to say ‘OK Google, set volume 40% on my Denon X4000’.

Running latest hassio.

What have you done to expose it?

1 Like

Media players have been updated to be a switch and have the volume trait exposed to Google Assistant, so you can turn them on/off and adjust the volume instead of the former brightness hack that was in place.

Sigh, yes, that works. I must have completely missed this in the change notes. A change for the better, but annoying to have missed it.

Ya I contacted the author of the PR who fixed it to figure out what was going on. :slight_smile:

1 Like

Can you provide a link to the PR or some instructions on how to configure denon with hassio and google assistant to regain volume control. I have not been able to locate any mention on this anywhere.

All you have to do is say "Hey google, set <device name> to <whatever>"

for example I say “Hey google, set the receiver to 85%” and it does it.

same here , works in denon, with hey google, set the … to xx

Doesn’t work for me. Google still think me denon is simply a switch.!
Here is a screenshot of the interface in the app. Does it look the same on your Google Home app?


This is my google configuration in hassio:

        - climate
        - switch
        - media_player.denon_avr_x2300w
        - climate.balcony
#        - climate.aquarium
        name: Stereo

Should I be including another domain perhaps?

My home app shows only On/Off as well, so what happens when you tell it “Hey Google, set the stereo to 75%” ?

Also what version of Home Assistant?

Same re, it’s on off but I can control volume level, no problem here

If you check under Cloud and Manage entities, does it says Volume as a trait? Mine says OnOff, Modes, Volume. Not sure what “Modes” are, but Volume works for increasing and lowering the volume, but I can’t tell it to set a specific volume. Annoying as hell.
Modes are sources apparently:

EDIT2: This might be Google assistant in Swedish that has hade some weird command change. The old commands for “volume amplifier xx” doesn’t work anymore. Also “set volume of amplifier to xx” doesn’t work, but “set THE volume of amplifier to xx” works. In Swedish that is.

i have exposed my denon as name “volume”, so i can just say
hey google, set the volume to xx

thats shorter :slight_smile:

I am on 0.103.6, currently upgrading to 0.104.2.

When I try to adjust the volume of the stereo like:
“hey google, set the stereo to 50%” --> Sets the volume of the google home device I am talking to.
“hey google, set the volume of stereo to 50%” responds with: “sorry, I did not understand that”.

My config as seen from the hassio gui: