Google Home mini with mi flora sensor don't work

Hi all,

I have a strange issue: I have many minis and many plants with mi flora sensor around the house but only one sensor works. The other (a copy paste with a different name and a different BLE mac adress is always unaivalable.

Did anyone had the same issue? How can I solve it?

Thank you in advance

How are you configuring it?

Hi Petro,

here’s the config for the sensor:

sensor:
  - platform: miflora
    mac: 'c4:7c:8d:67:3b:b0'
    name: Patty
    force_update: false
    median: 3
    monitored_conditions:
      - moisture
      - light
      - temperature
      - conductivity
      - battery
      
  - platform: miflora
    mac: 'c4:7c:8d:67:37:c9'
    name: Irene
    force_update: false
    median: 3
    monitored_conditions:
      - moisture
      - light
      - temperature
      - conductivity
      - battery
      

plant:
  Patty:
    sensors:
      moisture: sensor.patty_moisture
      battery: sensor.patty_battery
      temperature: sensor.patty_temperature
      conductivity: sensor.patty_conductivity
      brightness: sensor.patty_light_intensity
    min_moisture: 15
    max_moisture: 60
    min_conductivity: 350
    max_conductivity: 2000
    min_brightness: 1000
    max_brightness: 30000
    min_temperature: 10
    max_temperature: 35
    
  Irene:
    sensors:
      moisture: sensor.irene_moisture
      battery: sensor.irene_battery
      temperature: sensor.irene_temperature
      conductivity: sensor.irene_conductivity
      brightness: sensor.irene_light_intensity
    min_moisture: 15
    max_moisture: 65
    min_conductivity: 350
    max_conductivity: 2000
    min_brightness: 2000
    max_brightness: 30000
    min_temperature: 10
    max_temperature: 32    

Both mini see the plants as you may see below:

{
  "source_type": "bluetooth",
  "latitude": xxx,
  "longitude": xxx,
  "gps_accuracy": 0,
  "scanner": "GoogleHomeDeviceScanner",
  "rssi": -69,
  "btle_mac_address": "c4:7c:8d:67:37:c9",
  "ghname": "Corridoio",
  "btle_name": "Flower care",
  "friendly_name": "192.168.2.145 c4:7c:8d:67:37:c9"
}

{
  "source_type": "bluetooth",
  "latitude": xxxx,
  "longitude": xxxx,
  "gps_accuracy": 0,
  "scanner": "GoogleHomeDeviceScanner",
  "rssi": -67,
  "btle_mac_address": "c4:7c:8d:67:3b:b0",
  "ghname": "Google Home Mini",
  "btle_name": "Flower care",
  "friendly_name": "Patty"
}

It looks like you are configuring it correctly. Try removing the capital’s for your plant names in your plant sections.

plant:
  patty:
    sensors:
      moisture: sensor.patty_moisture
      battery: sensor.patty_battery
      temperature: sensor.patty_temperature
      conductivity: sensor.patty_conductivity
      brightness: sensor.patty_light_intensity
    min_moisture: 15
    max_moisture: 60
    min_conductivity: 350
    max_conductivity: 2000
    min_brightness: 1000
    max_brightness: 30000
    min_temperature: 10
    max_temperature: 35
    
  irene:
    sensors:
      moisture: sensor.irene_moisture
      battery: sensor.irene_battery
      temperature: sensor.irene_temperature
      conductivity: sensor.irene_conductivity
      brightness: sensor.irene_light_intensity
    min_moisture: 15
    max_moisture: 65
    min_conductivity: 350
    max_conductivity: 2000
    min_brightness: 2000
    max_brightness: 30000
    min_temperature: 10
    max_temperature: 32    

I’ve changed it but nothing happens.

I think is related to the mi flora sensor because for example the sensor “irene.moisture” is always unknown.

It’s possible. You could be running into a bug, it could be an issue with your hardware. Are there reporting options for the mi flora?

Dunno. Maybe you’re right. I will check with another mi flora sensor and keep you updated.

Nothing changed. Minis are not able to connect to all miflora around the house. Only first sensor works.

I’ll wait for 0.88 where I saw that device tracker has been rebuilt.

Ya, it’s possible you are running into a bug. I don’t have the sensor myself otherwise I’d look into the issue