Google Maps Stopped Working

Had this integration (https://www.home-assistant.io/integrations/google_maps) working just fine for the past 15 months or so. Stopped last night after a reboot. Showing this error in the logs:

Logger: locationsharinglib.Service
Source: /usr/local/lib/python3.8/site-packages/locationsharinglib/locationsharinglib.py:170
First occurred: 8:14:24 AM (47 occurrences)
Last logged: 9:00:24 AM

Received response code:500

I tried recreating the cookie, as well as commenting out configuration.yaml entries and rebooting numerous times w/ different iterations of installed / removed / commenting out known_devices.yaml

Anyone else seeing this issue / know how to resolve? Figured I’d ask here before posting to Git. Thanks in advance!

I have the same issue, with the same response code:500 in the log. A new cookie did not help. Go ahead and post to git.

I’m still on .118.5 and running Ubuntu 20.04.1 LTS. Happy to post it, but assuming I’m going to get yelled at for running and outdated version and unsupported system…

What are you running?

I have the same issue with the latest Home Assistant version. “Received response code:500” …over 500 ocurrenes. I tried getting “fresh” cookies, still same error. I think it started recently ( maybe 1 day?).

Clearly something going on w/ the underlying locationsharinglib.py or some other element. What version / system are you running on?

Same issue. Integration has been working for a few months untill yesterday. I am getting the same response code. Running the latest version.

I’m running the latest 2020.12.7 version on homeassistant os 5.10.

same issue here with latest version of H.A. Maybe a google server offline?!

Should have looked here first, but glad I’m not the only one. I opened a git bug earlier on this.

Thx for creating the Git issue. I commented w/ the error I’m receiving in my logs as well. Hoping it’s fixed soon - home / away definitely a critical component of dozens of my automations…

Copying my comment in case it helps somebody:

If you use docker version, here’s my barbaric attempt to band-aid this using Dockerfile:

FROM homeassistant/home-assistant:2021.1.1

RUN sed -i "s|requests==2.25.0|requests==2.25.1|g" /usr/src/homeassistant/requirements.txt
RUN sed -i "s|requests==2.25.0|requests==2.25.1|g" /usr/src/homeassistant/homeassistant/package_constraints.txt
RUN sed -i "s|requests==2.25.0|requests==2.25.1|g" /usr/src/homeassistant/setup.py
RUN sed -i "s|locationsharinglib==4.1.0|locationsharinglib==4.1.5|g" /usr/src/homeassistant/requirements_all.txt
RUN sed -i "s|locationsharinglib==4.1.0|locationsharinglib==4.1.5|g" /usr/src/homeassistant/homeassistant/components/google_maps/manifest.json

RUN pip install requests==2.25.1 locationsharinglib==4.1.5

Use build: . in your docker-compose instead of image: homeassistant/home-assistant:2021.1.1 and put Dockerfile alongside with docker-compose.yml

I’m not very familiar with how the homeassistant setup works but without replacing versions in actual files it keeps reinstalling old versions of specified libs on every restart.
Alternatively, you can simply risk and run dev-version, which I chose not to do.
(The problem is fixed in locationsharinglib==4.1.5, which is adopted in dev-version of hass-core, but not released yet)

2 Likes

Hi Boomka,
Thanks for sharing as I’m also looking forward to get this working.
I use the location in HA to alert me of my kid returning and going to school.
… a real impact here at home …
hope that new version would be avaialble in the short

Glad I’m not the only one that this has impacted. As an FYI, for anyone attempting to pinpoint the time this changed over - it was approx 12:17 GMT+8 on 12/1/21.

I too use this for a couple of automations and had to go back to doing things manually. Ugh, such a drag!

I have the same issue.
Running HA 2021.1.0 / Supervisor version 2020.12.7
After update yesterday Google Maps sharing doesn’t work anymore

Any progress in solution? I don’t know where to start. Have tried a new cookie

Sounds like the ‘fix’ is ready to go and is just awaiting release.

See final comment here: https://github.com/home-assistant/core/issues/45117

I would ask if @dshokouhi can please clarify his ‘next major release’ comment from Git. Does this mean 2021.1.2 or 2021.2.0?

The latter is clearly > 2 weeks away and this (at least for me) is a MAJOR issue not knowing if myself / wife / kids are home or away.

I know I personally have dozens of automations that depend on it (one such automation did not set my home alarm last night as an example…). Thx for any insight you can provide Daniel!

1 Like

2021.2 unless it gets tagged for a milestone and a release gets cut which I don’t know will happen sooner.

@Markus99 I feel your pain. I am an avid user of the Google Maps integration, but then also have owntracks as a backstop in addition to bluetooth device_tracker on all our phones. Either way, the Maps integration is the most informative and reliable. Fingers :crossed_fingers:t3: that the fix is a subversion release and not coming next month.

if you guys have an android device consider using the companion app, our device tracker also uses googles fused location services and we have done lots of improvements to it recently.

I agree, I know there’s other services and I also have some of them implemented but this is a major break in the reliability of my device tracking setup. Hopefully the fix can get pushed up to 2021.1.2

I do, fortunately, run Android, but currently don’t use the companion app, simply a bookmark to my DuckDNS URL and it works great. I personally despise add’l apps that are redundant and clutter my phone (ie. I use FB via web URL vs. their app). Definitely appreciate the interim fix suggestion.

If this is the only / best solution - then I’ll explore - but also guessing it requires add’l user setup and such vs. just ‘working’ as google_maps integrations has to date. I also realize I can setup owntracks, Google Wifi, bluetooth device trackers and the rest. I further realize this is working ‘beta’ software, just a critical component for many I’d guesstimate.

Any suggestions for how / where to strongly suggest to the powers that be to bump this up to 2021.1.2 vs the Feb 2021.2.0 release?

1 Like