Ha_dns not running after yesterday's upgrade

Hi all,
I am new here.

I updated home assistant yesterday to the latest version and since then I have issues with DNS:

21-02-06 11:22:33 INFO (SyncWorker_3) [supervisor.docker.dns] Starting DNS homeassistant/aarch64-hassio-dns with version 2021.01.0 - 172.30.32.3
21-02-06 11:23:03 WARNING (MainThread) [supervisor.misc.tasks] Watchdog found a problem with CoreDNS plugin!

I am running a raspberry pi 4 with “Linux raspberrypi 5.10.11-v8+ #1399 SMP PREEMPT Thu Jan 28 12:14:03 GMT 2021 aarch64 GNU/Linux”.

root@raspberrypi:~# docker ps -a
CONTAINER ID        IMAGE                                                  COMMAND                  CREATED             STATUS                        PORTS                  NAMES
e9b896d6727e        homeassistant/aarch64-hassio-dns:2021.01.0             "/init"                  14 seconds ago      Exited (159) 12 seconds ago                          hassio_dns
2021-02-07T12:09:45.080925191+01:00 container destroy 1e554bf73b8f0ff4670e9fbf689ede5c40be650afe5ad67cd6f418c8ee0c762f (image=homeassistant/aarch64-hassio-dns:2021.01.0, io.hass.arch=aarch64, io.hass.base.image=homeassistant/{arch}-base, io.hass.base.name=alpine, io.hass.base.version=2021.01.1, io.hass.type=dns, io.hass.version=2021.01.0, name=hassio_dns)
2021-02-07T12:09:45.305084340+01:00 container create d9b453d2b8bbe7f751afbfb9ae9121ab21544e816692b4e8c6eee0bb464b7882 (image=homeassistant/aarch64-hassio-dns:2021.01.0, io.hass.arch=aarch64, io.hass.base.image=homeassistant/{arch}-base, io.hass.base.name=alpine, io.hass.base.version=2021.01.1, io.hass.type=dns, io.hass.version=2021.01.0, name=hassio_dns)
2021-02-07T12:09:45.369051050+01:00 network disconnect 4a2c8dea93871f36fd40501dde37faf0ffb28e7ef995524bf159bde892616107 (container=d9b453d2b8bbe7f751afbfb9ae9121ab21544e816692b4e8c6eee0bb464b7882, name=bridge, type=bridge)
2021-02-07T12:09:45.434834596+01:00 network connect 5e5eb72b6d8ef8bbdf156b093720a238dea2139f6f64195eacae6f2d8b208c8c (container=d9b453d2b8bbe7f751afbfb9ae9121ab21544e816692b4e8c6eee0bb464b7882, name=hassio, type=bridge)
2021-02-07T12:09:46.297345688+01:00 container start d9b453d2b8bbe7f751afbfb9ae9121ab21544e816692b4e8c6eee0bb464b7882 (image=homeassistant/aarch64-hassio-dns:2021.01.0, io.hass.arch=aarch64, io.hass.base.image=homeassistant/{arch}-base, io.hass.base.name=alpine, io.hass.base.version=2021.01.1, io.hass.type=dns, io.hass.version=2021.01.0, name=hassio_dns)
2021-02-07T12:09:46.399706716+01:00 container die d9b453d2b8bbe7f751afbfb9ae9121ab21544e816692b4e8c6eee0bb464b7882 (exitCode=159, image=homeassistant/aarch64-hassio-dns:2021.01.0, io.hass.arch=aarch64, io.hass.base.image=homeassistant/{arch}-base, io.hass.base.name=alpine, io.hass.base.version=2021.01.1, io.hass.type=dns, io.hass.version=2021.01.0, name=hassio_dns)
2021-02-07T12:09:46.542340935+01:00 network disconnect 5e5eb72b6d8ef8bbdf156b093720a238dea2139f6f64195eacae6f2d8b208c8c (container=d9b453d2b8bbe7f751afbfb9ae9121ab21544e816692b4e8c6eee0bb464b7882, name=hassio, type=bridge)

my home assistant installation is a supervised one. I know it is not supported configuration but it worked before the update.
Please help me with a bit of troubleshooting.

thank you in advance,
Radu