HA does not boot from USB-SSD on Raspi4, weird partitions created

At first I used an existing A1 SD card just to try HA, now I would like to migrate to SSD in USB enclosure. All videos said it would work - unfortunately it does not.

Hardware: Samsung PM981 MZVLB512HAJQ - SSD - 512 GB - M.2 2280 in https://icybox.de/product.php?id=61 IcyBox USB NVME enclosure connected to the USB 3.0 port of a Raspi 4. As some people mentioned that there may be an issue with older eeprom versions I loaded a simple Raspbian to another SD card, updated eeprom to current version.

Then I tried both Balena Etcher & Raspberry Pi Imager to flash a HA image to the SSD. Raspi tries to boot from USB but just a few seconds green ACT light, then ACT LED is off and USB LED blinking. So I had a look at the partition table that the tools created and I found only one (!) partition of 32MB (!) which does show up in Explorer but does not start.


How do I get the imager tools to create a working installation on my USB SSD drive? What did I miss?

Start by trying with the USB 2 port. I think that suggestion was somewhere in the documentation, but anyhow it worked for me.

Also give it a bit more time to extend the partitions and create a whole bunch of stuff.

HA is using Linux, which might not be accessible in Windows Explorer.
HA is also only installing a skeleton system and then updating from the internet and setting everything up.
Give it some time and maybe watch the monitor now and then.
You should end up with a screen that tells you that HA is running and you can access it using some link.

Thanks, will try one of the black USB ports.

What exactly is meant with “give it time to extend the partitions”? Does it mean that it is normal that there is only this tiny partition and during the installation the real partition is done?

Every manual I read about “moving from SD to SSD” is giving the advice to make a snapshot, install HA on USB drive and load the snapshot. This is why I did it this way. Is it really impossible to copy the SD card to USB-drive?

The image you install on the drive only contains a 32Gb partition.
As part of the installation process it will grow that partition to fill up the drive.

32 GB would be pretty understandable - but this is 32 MB (!)

No - there are jobs that run to set up HAOS when it first runs. You will not run these on the SSD if you copy the image across and I doubt it will extend the file system or create correct partitions.

Use the recommended method, from the website not a video. Burn a new HAOS image for your Pi on the SSD. Boot from SSD and wait for all setup processes to finish - if you have a display plugged in you will eventually see a message. Then restore the snapshot.

As marked solved, my summary so far:

  1. Connecting to one of the black USB ports AND waiting for really, long time (way more than with SD card) did do the trick
  2. After it finally loaded, I included the snapshot - and then it really went down. So I will have to see how to get it up and running again but this will be a different story.