HA keeps crashing

Hello all,

Been trying HA for a couple of weeks now but it keeps crashing every couple of days.
sometimes twice a day sometimes after 5 days.
I do know what to do, in my mind I have tried everything.

Hardware:

  • Pi4
  • Sandisk Extreme Pro
  • Original Pi charger
  • Conbee stick

What I tried:

  • Full reinstall of HA without a reinstalling a backup
  • Tried several SD cards
  • Changed the charger
  • Reinstall without any integrations
  • Deleted the /config/home-assistant_v2.db
  • Been logging memory, temperature and processor but nothing strange to see there

I tried accessing the Pi when it crashed but I could not access it through Samba share and my router did not see the Pi as a connected device.

After removing the power the Pi starts up as normal as is nothing is wrong

After reboot this is in my log:
2021-05-25 19:03:06 WARNING (Recorder) [homeassistant.components.recorder.util] The system could not validate that the sqlite3 database at //config/home-assistant_v2.db was shutdown cleanly

2021-05-25 19:03:06 WARNING (Recorder) [homeassistant.components.recorder.util] Ended unfinished session (id=6 from 2021-05-21 06:55:28.856961)

Because of this I deleted my /config/home-assistant_v2.db last time.

Can someone help me please?

This is a long shot, but my HA (hosted on a raspberry pi4 ) started freezing almost every day after many months of reliable operation. I assumed an update had introduced a memory leak. But I had also moved the pi from my desk to its permanent wall mounted location. The new location did not yet have a surge protector. Once I eventually installed the surge protector, my HA has not crashed once (going on 2 weeks straight).