HA OS on unRaid!

Anyone here have issues with Lifx and Unraid 6.8X? On 6.7 bulb control and discovery worked fine, something has changed in 6.8 and this no longer works. For a long time I just stayed on 6.7 figuring it would work out in one of the point releases.

Could be networking related, I think Lifx is using UDP.

Problem solved:

For some reason UDP discovery doesn’t seem to work on Unraid 6.8. I have to create a broadcast address for each Lifx bulb manually in the configuration. Luckily I already had static IP’s for everything Lifx.

I can manually downgrade to 6.7 all day and have this work but something related to UDP discovery is definitely different. I figure I can ask over on the Unraid forums and perhaps someone over there knows the answer.

Hi all,

I just moved my Home Assistant (hass.io) from Synology to unraid using a snapshot and I have some issue with some add-on (deconz) and principally with hassio_supervisor who crash few minutes after start with error 137.

Did anyone had same issue and knows to solve it?

Thank you

Has anyone had any issues with Home Assistant doing a ton of writing? I’ve averaging 15-40MBps of writes to my cache drive that I have the VM installed on. When I stop Home Assistant and turn the VM off, that drops to a few KBps. Also, the drive has seen 119TB of writes to it since I installed it in October and the vast majority of that has been Home Assistant related.

I’m concerned I’m going to wear out my cache drive as it does so much writing. I’ve gone down the whole route of limiting what the Recorder actually writes, but it doesn’t seem to help much. I’m running a decent amount of add-ons, like Node-Red and VSCode, but nothing that I can specifically find is writing a ton of data…

Have some of you migrated to an external DB or put the VM on a ramdisk?

1 Like

Will there ever be a solution for the long restarts? Feels like it’s around 30 min now.

Is this connecting locally or remotely that it takes that long?

Just local on my unraid box.

Are you running in a VM on unraid?

That’s not normal. If anything restarts are much faster unless you don’t have the resources allocated.
Or there’s something unique to your HA instance. Hard to tell without more info.

as docker containers. No VM.

Issue seems related about timing.

That’s a very buggy choice and not supported. This thread is about using a VM within Unraid.

Yes, as a VM in unraid.
Allocated 4 x Cores of an i7 processor, plenty of RAM and running off of Samsung SSD’s.

Never used to be like this, just changed over time.


I think i messed up. Have hassio running on ubuntu in docker on a nuc. Want to migrate to unriad and followed the guide.

When i set up the hassio before making the restore from snapshot I choose the same username as I have on Nuc hasso.

So when the snapshot restored I didn´t make full migrate. Everything don´t look the same. For exemple I have not HACS.

I have logged out and in after the snapshot.

Even tried to delete VM and make from scratch but same result. I quess the app data is the same, I don´t know how to fix this.

Move from NUC Docker to Unraid
I possible keep same IP as I will not have to change all mqtt devices.


This is not an unraid issue. You should check your snapshot and make sure everything is in it. You also don’t need to create the same user. You can make a throwaway user and then when you restore the snapshot choose “wipe and restore”. Your old user will be restored and the temporary one should be gone. It’s also good to reboot the VM (supervisor > system page in the UI) after a restore.

Since upgrading to 0.108 that slow restart issue has disappeared.

Been running hassio as a vm for a while and been working great.

Today I added a pre flashed LSI card and Hassio VM will boot but gives me the Hass OS boot screen

  1. Autoboot
  2. Boot System 0
  3. Boot System 1
    4 SHell

Im stuck.

And alot of tried I get the guest has not initialized the screen problem.

Before I put in LSI card all was 100% prefect.

The card found the disk (thats not the problem)

My win10 win is running perfect, I´m on it now.

What to do?

Change back the unassigned disk to my mobo sata?

1 Like

My hass.io is running for a year now on my unraid. The slow boots is no issue anymore.

Only thing that still does not work is my USB Bluetooth LE adapter pass trough. I can pass my TI Zigbee controller and my ESP32s without any issue. Tried different Bluetooth dongles, never worked. Still bugs me.
Is it a unraid or a hassio problem?

I’ve been running Unraid and HA in a container for a year. I’m no Linux or HA expert. I just saw some comments above about high amounts of writes on SSDs and missing bluetooth dongles and I would like to share my experience.

@MagicMountainMan Unraid uses btrfs for its cache pool. I was running two NVMe in RAID1 and I too saw high amount of writes. At first I thought it was CoW enabled for docker.img, but no - system and domains shares have it off. However, it is enabled for appdata where HA db is located. I think the issue is btrfs pool specific. I have converted/balanced the pool to single mode. I do see less IO, but still higher because of CoW on appdata. I hope kernel 5.5 in Unraid 6.9 will fix that.

@dedi I’ve tried to pass bluetooth dongles to my docker container. Unfortunately, Unraid kernel have explicitly removed all bluetooth drivers/firmware. Even though the device is visible it cannot be started. I have read somewhere that the host OS should support the device in order to be available in the container. I have no idea if this is true also for qemu and VMs. It looks like it is a problem for you.

I have ordered five ESP32s to convert them to ESPHome bluetooth-MQTT hubs. and forget about native bluetooth support

I’m still thinking, if I need a VM with HassIO for the great plugin integration or should I stick to a simple container.

I hope my ramble helps some of you.

1 Like

Afaik there was bluetooth support added like a year ago or so in Unraid. Unfortunately that didn’t help.

I went also with ESP32s but still want Bluetooth on host for different things.

You’d have to confirm that your device has driver support from the HA OS. There are better ways to make use of bluetooth if using it for presence. Monitor.sh, Room Assistant are a a couple. Then you’d have the sensors reporting in to your “hub” instead of needing to be attached to it.

1 Like