Ha os update - Error: Error raised from OTA Webserver: 404

Tags: #<Tag:0x00007fc42f966338> #<Tag:0x00007fc42f966248>

Environment:

core-2021.5.5
supervisor-2021.06.3
Home Assistant OS 6.0
raspberry pi4

The problem:

I’m trying to dowgrade to 5.3 since I’m facing stability issues described in HASS unstable #1119.

I’ve tried

# ha os update --version 5.3
Error: Error raised from OTA Webserver: 404
# ha os update --version 5.13
Error: Error raised from OTA Webserver: 404

With debug option

# ha os update --version 5.3 --log-level debug
time="2021-06-18T08:07:25+02:00" level=debug msg="Adding homedir to searchpath" homedir=/root
time="2021-06-18T08:07:25+02:00" level=info msg="No configfile found"
time="2021-06-18T08:07:25+02:00" level=debug msg="Debug flags" apiToken=7cca91a659c193dc3c5a56e60c9aa790587f1db5b0d286261f70020e181956ba962be4e7afa99e8bc0735e5719688817a3738e0589b6bb27 cfgFile= endpoint=supervisor logLevel=debug noProgress=false rawJSON=false
time="2021-06-18T08:07:25+02:00" level=debug msg="os update" args="[]"
time="2021-06-18T08:07:25+02:00" level=debug msg="[GenerateURI]" base=supervisor command=update section=os
time="2021-06-18T08:07:25+02:00" level=debug msg="[GenerateURI] Result" uri="http://supervisor/os/update" url="http://supervisor/os/update" url(string)="http://supervisor/os/update"
time="2021-06-18T08:07:25+02:00" level=debug msg="Request body" body="map[version:5.3]"
time="2021-06-18T08:07:25+02:00" level=debug msg=Response body="{\"result\": \"error\", \"message\": \"Error raised from OTA Webserver: 404\"}" fields.time=333.119753ms headers="map[Content-Length:[70] Content-Type:[application/json; charset=utf-8] Date:[Fri, 18 Jun 2021 06:07:25 GMT] Server:[Python/3.9 aiohttp/3.7.4.post0]]" received-at="2021-06-18 08:07:25.78733487 +0200 CEST m=+0.341077549" request="&{POST http://supervisor/os/update HTTP/1.1 1 1 map[Accept:[application/json] Authorization:[Bearer 7cca91a659c193dc3c5a56e60c9aa790587f1db5b0d286261f70020e181956ba962be4e7afa99e8bc0735e5719688817a3738e0589b6bb27] Content-Type:[application/json] User-Agent:[go-resty/2.6.0 (https://github.com/go-resty/resty)]] {} 0x2d4268 17 [] false supervisor map[] map[] <nil> map[]   <nil> <nil> <nil> 0x10a402c}" status="400 Bad Request" statuscode=400
Error: Error raised from OTA Webserver: 404
#

When checking with journalctl -xe

Jun 18 06:07:25 homeassistant hassos-supervisor[958]: 21-06-18 06:07:25 INFO (MainThread) [supervisor.hassos] Fetch OTA update from https://github.com/home-assistant/operating-system/releases/download/5.3/haos_rpi4-5.3.raucb
Jun 18 06:07:25 homeassistant 7946f713f130[467]: 21-06-18 06:07:25 ERROR (MainThread) [supervisor.hassos] Error raised from OTA Webserver: 404

The URL is attempting to download an haos* file, however it does not exist:
https://github.com/home-assistant/operating-system/releases/download/5.3/haos_rpi4-5.3.raucb

The correct URL seems to b with hassos* instead:
https://github.com/home-assistant/operating-system/releases/download/5.3/hassos_rpi4-5.3.raucb

I’ve tried many things, all with the same failing result:

  1. ha su reload
  2. full host/core restart
  3. fresh image in a new SSD with hassos 6.0

I know I can also upgrade via USB, however I’m facing another type of issues with this approach, I might open a new topic for this too.

Thanks all in advance,

1 Like

I’m having the same problem, need to downgrade to 5.4. The USB upgrade does not work either, not sure why, I tried different naming/format combinations and nothing.