HA SwitchPlate - DIY LCD Touchscreen wall switch replacement


#993

If it’s not page 0 then also check your connection. I thought I checked and double checked by my connections were switched for rx and tx. Switched them and it was good to go.


#994

thanks but no further along, blue to D7 and yellow to D4 as per assembly documentation, tried switching and rewiring but no change. Checked active screen as per myle’s suggestion as well still stuck on page 0.

don’t know if this helps debugging but have this output from plate webpage:

MQTT Status: Connected
MQTT ClientID: plate01-b4e62d4563e3
HASP Version: 0.37
LCD Model:
LCD Version: 0
LCD Active Page: 1
CPU Frequency: 160MHz
Sketch Size: 575248 bytes
Free Sketch Space: 2568192 bytes
Heap Free: 16648
Heap Fragmentation: 1
ESP core version: 2_5_0
IP Address: 192.168.2.220
Signal Strength: -63
Uptime: 327
Last reset: Fatal exception:0 flag:6 (EXT_SYS_RST) epc1:0x00000000 epc2:0x00000000 epc3:0x00000000 excvaddr:0x00000000 depc:0x00000000

Not sure of it matters but only thing that jumped out at mess was the blank LCD Model and Version


#995

If all you are seeing is “HASP Initializing” with no QR code that suggests the WeMos is not sending data to the Nextion. Can you maybe post pics of your setup?


#996

Thanks - Replaced the wemos and that problem now resolved. Short lived success though as now the touchscreen is unresponsive - can change pages, colour etc through the home assistant interface but no response to touch on Nextion :frowning:


#997

So similar process there, you need to make sure that data both to and from the panel is working correctly. If you can make HASP switch pages and the like, that means TX from HASP is getting to RX on the panel. If button presses aren’t being picked up, check to make sure TX from the panel is making it to RX on the HASP. If you have a serial connection open you should be able to see user interactions sent by the panel displayed in the serial log.


#998

Greetings,
I just built an HA SwitchPlate and things seem to be going okay as far as configuring the screen.
However, I’m not getting any activity on (touchscreen) button press. The button does visually depress, but there are no messages on the hasp/plate01/state topic coming from the HASP. I can change the look of the HASP just fine with the hasp/plate01/command/blah messages so MQTT seems to be working okay, in one direction at least. Any idea where I could look to troubleshoot this?

EDIT: I just happened to notice this in the output of the bash script:
WARNING: Required MQTT broker configuration not setup in configuration.yaml

My MQTT is setup as an “integration” versus a line in configuration.yaml, could that be what is causing my issue?


#999

so have you setup the switchplate automations in nodered instead of hassio yaml?


#1000

No the switchplate automations are in hassio yaml (from the deployment script) its just the MQTT broker config is not on config.yaml, its setup as an “integration” instead.


#1001

Where are the automations?
I do not see them in hasp.demo.yaml.


#1002

Yes, all of them except the alarm panel and backlight by sun (just haven’t had time to get to it). If you use the NodeRED export I shared a few posts ago, you need to disable all of the automations in the packages supplied by luma. And just as his pre-configured automations, you can go through and modify these to see fit (e.g. don’t use spotify? change the nodes to the music provider of your choice).


#1003

There’s a lot going on in this thread so I’m not sure if those latest replies were even meant for me, but for some added clarification, this is what I’m talking about:

  # Trigger scene.daylight when p[1].b[5] pressed
  - alias: hasp_plate01_p1_SceneButton5
    trigger:
    - platform: mqtt
      topic: 'hasp/plate01/state/p[1].b[5]'
      payload: 'ON'
    action:
    - service: scene.turn_on
      entity_id: scene.hallway_light

When pressing page 1 button 5 , the state message doesn’t ever make it to my MQTT broker. Nothing really happens at all when I press the touch screen buttons as far as I can see.


#1004

Do you see the message on the MQTT broker? Are you confident that your Home Assistant installation is configured to use your MQTT broker?


#1005

Yes, I can go to the “plate01” page in HA and control the touch screen and I see those MQTT messages in MQTT.fx
Its only the other direction that there is an issue, pressing the touch screen does not generate MQTT messages. Any idea where I should look to troubleshoot?


#1006

Can you enable telnet debug, connect via telnet, and grab a log of output when you’re pressing buttons?


#1007

Absolutely nothing appears in the telnet session when pressing the touchscreen buttons.

When controlling HASP from HA I do see some activity…
Connected to 10.0.71.127.
Escape character is ‘^]’.
[+159.640s] MQTT IN: ‘hasp/plate01/command/page’ : ‘2’
[+159.649s] HMI OUT: page 2


#1008

This strongly suggests that TX from the panel isn’t getting to the ESP8266. Was this purchased as an assembled unit? If so I can arrange a replacement right away. If this is self-built, can you post pics of the connections?


#1009

Self-built… It’s just “bench” built for now.
Now that I have some direction on where to look I’ll check that out… Thanks


#1010

Thanks, I found a bad solder job between the D1 mini and the HASP-PCB on pin D7. All is well now.


#1011

I looked back through all of the posts and noticed that HASP won’t work with HA while using SSL. Has a way been determined to make them both play nice? I’m trying to get the switch up and running but I keep being met with the WIFI CONNECTED: MQTT CONNECTED: page 0. I’m so confused.


#1012

I have HASP installed and my HA install has SSL… works just fine. HASP uses the MQTT component and either a local or hosted MQTT server to talk to HA and for HA to talk to HASP. As long as your HASP is connected to WiFi and an MQTT broker, and you have the package installed in HA correctly, you will have full control of HASP from the HA frontend. If it is saying page 0, then use the page slider on HA frontend to change to page 1, 2, etc. If everything is connected and communicating, you’ll see the page change.

EDIT: most likely what you saw is that the configuration page from the HA frontend using panel_iframe doesn’t work on the HA frontend if using SSL for HA. That is correct and is a limitation of panel_iframe. You can still directly access the web configuration page of HASP at its IP address.