Home Assistant Community

HA SwitchPlate - DIY LCD Touchscreen wall switch replacement

#1013

The only part that doesn’t work is integrating the admin web interface as a panel/iframe within the HA web interface. Everything else should work as expected, but only in the “states” web UI as Lovelace still doesn’t support packages making it impossible to cleanly integrate outside projects like HASP. For the admin web interface you can still just hit the IP/mDNS name of the HASP device in a new browser tab.

In regards to the page 0, can you switch the current page to a new page in the HA UI?

0 Likes

#1014

No, I can’t switch the page in the HA UI. It shows as unavailable.

0 Likes

#1015

Thank you. That answers the ssl issue. Now to get this thing to switch pages, cause page 0 is boring. LOL

0 Likes

#1016

Do you see MQTT traffic on your broker when HASP starts/restarts?

0 Likes

#1017

I can connect to the broker with mqtt.fx and see the traffic from the HASP to the broker. But that’s all that I see. No other traffic.

0 Likes

#1018

I deleted and reinstalled everything twice. Messed with some MQTT settings and such. Finally got them talking to one another.

1 Like

#1019

I would like, after touching the display and changing the page, to return to my main page after a certain number of seconds.
I don’t understand what to change, can you help me?
Thanks

0 Likes

#1020

Hey @luma, what’s the situation with legacy authentication and HASP? I’m having an issue where my MQTT broker is getting blocked and the IP address being banned. This isn’t an issue with HASP, but most likely an issue with MQTT as an integration and the recent changes in deprecating legacy password authentication. Just wondering if you’ve encountered this and if you’ve had to change anything because of it.

EDIT: I’m wondering if I need to remove the mitt.yaml file I have and switch to making it an integration instead…

0 Likes

#1021

HASP and MQTT don’t utilize Home Assistant authentication in any real sense. HASP can utilize MQTT auth, but that’s unrelated to HA auth and the ongoing changes around that.

0 Likes

#1022

ok, so it’s an issue with my MQTT broker. I just upgraded to 0.90.2 today and removed legacy authentication and I started noticing failed logins related to when I was using HASP.

0 Likes

#1023

Are you using hassio with the mosquitto addon? If so, read the warning on this page https://www.home-assistant.io/addons/mosquitto/

0 Likes

#1024

Nope.
HA and MQTT in separate docker containers on a Synology. I’m pretty sure my issue has to deal with me prematurely disabling legacy authentication and removing the api password from my config. My MQTT broker was trying to login but was getting blocked due to invalid authentication. I’ve yet to play around with it again and try to switch things over to user authentication instead.

0 Likes

#1025

Your MQTT broker does not “log in” to home assistant.

0 Likes

#1026

You’re right it doesn’t. For simplicity sake I made my HA and MQTT username/password the same way back when I set it all up. I was confusing myself with how HA and MQTT talk. I’ll have to go check some of my other devices that I know log in to HA like my iPad and make sure they aren’t using legacy authentication then.

0 Likes

#1027

In general, all connections to an MQTT broker are incoming - it shouldn’t need to authenticate back to Home Assistant, instead Home Assistant authenticates to MQTT (as does HASP and whatever else). The only exception to this is if you are using bridge functionality, but you’d know it if you were.

0 Likes

#1028

Luma, thanks so much for creating and supporting this project. Can you tell me where I go to comment out the HASP iframe? I am running Lovelace with SSL and am using the state page for configuration. I would like to “clean up” from LL gui. I have search every file I could find and check the forums, reddit ect…

Thanks
Tika

0 Likes

#1029

if u are asking about this

image

that should be in the packages/plate01/hasp_plate01_00_components.yaml

plate01 being replace with what every you call it.

1 Like

#1030

Good gravy that was easy. Sometimes you get so wrapped around something you cannot see the forest for the trees. Thanks for the help!!

0 Likes

#1031

Forgive me if this has been discussed. I searched the thread for the keyword “esphome” and didn’t find anything. What is the possibility of converting/configuring HASP to use esphome? It would accomplish a couple things in my mind. It removes the dependency on an MQTT broker by shifting the API to the native esphome and leveraging HA discovery platform. Additionally it allows the quick programming of the Wemos D1 Mini (ESP8266 chip) using OTA for future use of other GPIO on the board. esphome already supports the Nextion family of displays as well. esphome is it’s own server and wouldn’t rely on an external or internal HA MQTT broker. The downside is refactoring all of the base code to use the ephome yaml format and I don’t know how it would handle automatic updates or a web frontend, etc.

0 Likes

#1032

Hard pass on ESPHome for me. There’s a couple deal breakers which keep me away:

  • The API integration isn’t great - devices that use deep sleep will constantly report unavailable. You need to disable the API for these and use MQTT anyway to get around this (it’s directly in their docs).
  • Every Sonoff device I’ve tried it on which has been running Tasmota without issue for well over a year now… just doesn’t work. Won’t connect to wifi, won’t boot, other misc issues. Having to go get these devices to manually reflash them again by opening them and getting access to their pins has been a real bummer. As soon as I give up and bring them back to Tasmota all of the issues go away.

For this project the Arduino sketches are available and I’ve felt that ESPHome isn’t necessarily any faster when it comes to enabling extra logic/GPIO pins anyway.

0 Likes