HA works on iOS but not with Android

Hello everybody !!

I’m pretty close to creat the Jarvis from my dream, but I blocked on my girlfriend’s phone…

I’ve got HA on 0.39.3 (error when I try to install 0.40) with Nginx, Letsencrypt, and duckdns. It works very well from indoor and outdoor with my iPhone.

But my girlfriend with her Android phone can’t access to HA outdoor (but no problem on wifi) !
With our computers from our differents works it works to !
It’s really strange…

Do you need an idea ?

Thank you !

I have a Galaxy S7 that works without issue from outside, same setup DD, LE, Nginx. So don’t think its an Android issue specifically. So I’ll throw a couple darts in the dark here. Have you tried clearing browser cache on the android? Are you typing the URL out manually every time? I’m thinking maybe it’s trying to still use the internal address when off wifi. What type of error do you receive?

Hi !
thank you for your answer !
Yesterday morning it doesn’t worked, yesterday evening it worked, I don’t understand !
But it doesn’t matter…