HACS don't work and show "1 pending update(s)"

Tags: #<Tag:0x00007f32749b80b8>

Hello to all

sorry for my first topic, but it’s 3 day that i try to have HACS after my installation of home assistant

Summarize:
i’ve installed Home assistant with docker on my raspberry pi4, and i want to integrate HACS on this; i’ve follow the guide to add the HACS on homeassistant and after 3-4 times with error of GitHub Token, i see on the left the HACS link

to start and the box on the integration; but if i want to open HACS to have a integration for new project on my server, HACS didn’t load

Only things that i see on my dashboards is the below

What i’m wrong? Why HACS didn’t load?

Thanks for your support

If you see ‘1 pending update’, it must be that HACS is loaded.

Ok,
but at this point i don’t see anything else from the HACS

and same thing if i search a custom components… :upside_down_face: :frowning:

How did you install hacs? I find the command line method best.

I’ve try to install with command line with

cd /usr/share/hassio/homeassistant/
mkdir custom_components
cd custom_components/
git clone https://github.com/custom-components/hacs.git hacs_temp
cd hacs_temp
git checkout $(git describe --tags --always $(git rev-list --tags --max-count=1000) | grep -e "[0-9]\+\.[0-9]\+\.[0-9]\+$" | head -n 1)
cd ../
cp -r hacs_temp/custom_components/hacs hacs
rm -R hacs_temp

after ther rebooot of the system i’ve try to add HACS in 2 metods without solved

1 solution
to add

hacs:
  token: token_github
  appdaemon: true
  python_script: true
  theme: true

at the reboot of HomeAssistant i don’t find the HACS menu

2* solution
with integration add “HACS” with error

What i’m wrong?

Hello to all

solved, you can close this this topic

by the way: i’ve removed the “custom_components” dir and the HACS folder on the .storage dir

After reboot, i’ve re-installed with command line and new GitHub Token

Thank to all

Note for future users, the script always worked for me: