Hacs install going wrong

hacs install going wrong…

im trying to install hacs and i followed the instructions step by step - i copied over the hacs folder to a subfolder called custom_configuration under the config folder. something i see though is the .translations folder is showing as hidden - even if i mark it as unhidden it reverts back to hidden

when i go to integrations and click add HACS doesnt show up…any ideas what im missing here? running hass.io on rpi3b+

are you restarting?

And refresh the page.

should be named custom_components

This typo fix worked for me. I’d put in;
custom_component
OK now I corrected this to
custom_components
Thank you.

I am trying to install HACS and I keep encountering an error "Unknown error occurred
"… tried with two different github access tokens and tried re-downloading hacs.zip… have no idea what I could be doing wronge… any ideas?

Yes. My HACS installation was working fine until yesterday. Today it disappeared. No idea why. Trying to reinstall it, I get stuck when entering the github token. “Unknown error occurred”

Same exact issue. I attempted to uninstall/reinstall HACS and I get “Unknown Error” when adding the Github personal token

Looks like this could be a ratelimit error. I tired again after 1 hour and it worked.

Traceback (most recent call last):
  File "/usr/local/lib/python3.8/site-packages/aiohttp/web_protocol.py", line 418, in start
    resp = await task
  File "/usr/local/lib/python3.8/site-packages/aiohttp/web_app.py", line 458, in _handle
    resp = await handler(request)
  File "/usr/local/lib/python3.8/site-packages/aiohttp/web_middlewares.py", line 119, in impl
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/real_ip.py", line 39, in real_ip_middleware
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/ban.py", line 73, in ban_middleware
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/auth.py", line 127, in auth_middleware
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/view.py", line 129, in handle
    result = await result
  File "/usr/src/homeassistant/homeassistant/components/config/config_entries.py", line 145, in post
    return await super().post(request, flow_id)
  File "/usr/src/homeassistant/homeassistant/components/http/data_validator.py", line 60, in wrapper
    result = await method(view, request, *args, **kwargs)
  File "/usr/src/homeassistant/homeassistant/helpers/data_entry_flow.py", line 106, in post
    result = await self._flow_mgr.async_configure(flow_id, data)
  File "/usr/src/homeassistant/homeassistant/data_entry_flow.py", line 153, in async_configure
    result = await self._async_handle_step(flow, cur_step["step_id"], user_input)
  File "/usr/src/homeassistant/homeassistant/data_entry_flow.py", line 201, in _async_handle_step
    result: Dict = await getattr(flow, method)(user_input)
  File "/config/custom_components/hacs/config_flow.py", line 41, in async_step_user
    if await self._test_token(user_input["token"]):
  File "/config/custom_components/hacs/config_flow.py", line 66, in _test_token
    await get_repository(session, token, "hacs/org")
  File "/config/custom_components/hacs/helpers/functions/information.py", line 48, in get_repository
    raise HacsException(exception)
custom_components.hacs.helpers.classes.exceptions.HacsException: GitHub Ratelimit error

Hi all, I had HACS installed but after an update it broke me so I removed it. Now I’m trying to install it but I can’t. The whole operation is fine, but I don’t see it in the left bar. Already updated the page and deleted the history and cookies.
Basically, I deleted the entire old HACS folder and copied a new one, created a new token and installed via “integrations” … where did I go wrong? Where am I going to hit my head ??

You should have removed hacs the proper way, not by simply deleting the old hacs folder. There are remnants of the old installation in .storage.

1 Like

Thanks for the reply.
So I proceed like this, delete the integration, delete the HACS folder inside custom-components and then delete the folders (hoping to find the right ones) inside .storage, right?
After that I proceed to create a new token and clean install. What do you say?

That should do it.

forgive my poor command of the system …
Where do I find the .storage folder?

It is a hidden directory under /config

yep, found via ls -a in SSH :slight_smile:
Inside I have three HACS files, delete and reboot, after which clean install. Quite right?
I hope this post will be useful to others in the future too :slight_smile:

That should do it.

1 Like

everything ok, it works now! There were the last traces left in the .storage folder blocking everything.
Thanks thanks thanks