HADashboard error message

I have problem when I try to config/start HADashboard.
I run it on a Ubuntu 16.04 and my HASS server is also Ubuntu 16.04 (with commodo cert)
Can anyone help me with what could be the problem, see the error I get when running
‘sudo python3 -m appdaemon.appdaemon -D DEBUG -c /appdaemon_dashboard/appdaemon/conf/’

2017-06-30 10:22:54.287703 INFO App initialization complete
2017-06-30 10:22:54.290154 WARNING Disconnected from Home Assistant, retrying in 5 seconds
2017-06-30 10:22:54.290291 WARNING ------------------------------------------------------------
2017-06-30 10:22:54.290390 WARNING Unexpected error:
2017-06-30 10:22:54.290509 WARNING ------------------------------------------------------------
2017-06-30 10:22:54.290737 WARNING Traceback (most recent call last):
File “/appdaemon_dashboard/appdaemon/appdaemon/appdaemon.py”, line 1328, in appdaemon_loop
ws = create_connection("{}/api/websocket".format(url))
File “/usr/local/lib/python3.5/dist-packages/websocket/_core.py”, line 487, in create_connection
websock.connect(url, **options)
File “/usr/local/lib/python3.5/dist-packages/websocket/_core.py”, line 211, in connect
options.pop(‘socket’, None))
File “/usr/local/lib/python3.5/dist-packages/websocket/_http.py”, line 77, in connect
sock = _ssl_socket(sock, options.sslopt, hostname)
File “/usr/local/lib/python3.5/dist-packages/websocket/_http.py”, line 182, in _ssl_socket
sock = _wrap_sni_socket(sock, sslopt, hostname, check_hostname)
File “/usr/local/lib/python3.5/dist-packages/websocket/_http.py”, line 138, in _wrap_sni_socket
context.load_verify_locations(cafile=sslopt.get(‘ca_certs’, None), capath=sslopt.get(‘ca_cert_path’, None))
TypeError: cafile, capath and cadata cannot be all omitted

i suspect that the problem is in your websocket version.
but i dont remember what version it should be.

its a problem that some others had too.
i am sure the solution is somewhere in the 4 threads “announcement - hadashboard …”
thats a lot to read, but you can learn a lot from those threads :wink:

Also, can you post your config please

I’m using a comodo certificate to my HASS machine, not sure if that could some problem?

AppDaemon:
  logfile: STDOUT
  errorfile: STDERR
  threads: 10
HASS:
  ha_url: https://mydoamin
  ha_key: MyPassword
HADashboard:
  dash_url: http://IPToMyHADashboard:5050
# Apps
hello_world:
  module: hello
  class: HelloWorld

Some users have reported issues with self signed certs , and have had better luck using a commtype of SSE - I put a fix in for that. I’ll be looking at a fix for websockets when the beta is complete.

this is not a self signed, I bought it from Comodo, https://www.comodo.com

Can you try with --comtype SSE and let me know if it works.

Do you want me to start the HADashboard like this

‘sudo python3 -m appdaemon.appdaemon -commtype SSE -D DEBUG -c /appdaemon_dashboard/appdaemon/conf/’

Yes please!

Yes, it’s working now with the extra command.

Many thanx for the help.

Cool - I need to fix Web Sockets so it works too - I’ll be working on that soon.