HASS Configurator SSL

I want to use same ssl keys but I cant configure. I use hassio at RPi 3.

The config:
“certfile”: “/config/fullchain.pem”,
“keyfile”: “/config/privkey.pem”,
“ssl”: true,

The error:
starting version 3.2.4
INFO:2018-01-21 13:53:54,653:main:Starting server
Traceback (most recent call last):
File “/configurator.py”, line 3741, in
main(sys.argv[1:])
File “/configurator.py”, line 3731, in main
server_side=True)
File “/usr/lib/python3.6/ssl.py”, line 1149, in wrap_socket
ciphers=ciphers)
File “/usr/lib/python3.6/ssl.py”, line 747, in init
self._context.load_cert_chain(certfile, keyfile)
FileNotFoundError: [Errno 2] No such file or directory

1 Like

SSL = true as you are using keys

remove the / config as well

“certfile”: “fullchain.pem”,
“keyfile”: “privkey.pem”,
“ssl”: true,

Nothing!

The config:
“certfile”: “fullchain.pem”,
“keyfile”: “privkey.pem”,
“ssl”: true,

It seems that the files are not there… I copied to /config dir.
Regards.

SSH to your HASS.IO and check if you have the files as follow:

[root] /ssl/fullchain.pem
[root] /ssl/privkey.pem

You should not have any ‘/’ in the config

1 Like

Nothing. I put fullchain.pem and privkey.pem inside root/ssl folder…
Home-Assistant works using /config/ path for ssl files.

FileNotFoundError: [Errno 2] No such file or directory

In what location is it positioned?

Nobody? Please

Mine says this:
starting version 3.2.4
INFO:2018-01-27 09:19:26,235:main:Starting server
INFO:2018-01-27 09:19:26,241:main:Listening on: https://0.0.0.0:3218
INFO:2018-01-27 10:10:32,234:main:Requesting authorization

Can you post your full config settings please? It’s hard to tell if something else is not screwed up.

Also what URL for the Configurator have you defined in configuration.yaml?

@DavidFW1960

{
“username”: “xxxxxx”,
“password”: “xxxxxx”,
“certfile”: “fullchain.pem”,
“keyfile”: “privkey.pem”,
“ssl”: true,
“allowed_networks”: [
“192.168.1.0/24”
],
“banned_ips”: [
“8.8.8.8”
],
“banlimit”: 0,
“ignore_pattern”: [
pycache
],
“dirsfirst”: false
}

you have allowed a local address, 192.168.1.0/24 but if you are using SSL, the connection will be from a different address - like mydomain.duckdns.org, not that local address.

try using 0.0.0.0/0 as the allowed address.

you didn’t post what the configurator url you are using is -

mine looks like this: configurator: https://mydomain.duckdns.org:3218

also, there are new options in version 0.2.5 whereby you can use a sesame as in opensesame…

to use sesame, you would use a url like : configurator: https://mydomain.duckdns.org:3218/secretsesamepassword

and your configuration would look like this:

{
  "username": "secretuser",
  "password": "secretpassword",
  "certfile": "fullchain.pem",
  "keyfile": "privkey.pem",
  "ssl": true,
  "allowed_networks": [],
  "banned_ips": [
    ""
  ],
  "banlimit": 5,
  "ignore_pattern": [
    "__pycache__"
  ],
  "dirsfirst": true,
  "sesame": "secretsesamepassword"
}
3 Likes

Works now! Thanks :slight_smile:

Thank you for your help!

Thankyou, I had the exact same problem, that made it work here as well, terrible docs!