Hass.io install not working for me

Not sure if this belongs in the Instillation or Hass.io category, but here goes.

I’m trying to follow these instructions https://www.home-assistant.io/getting-started/ and not sure where I’m going wrong, they’re fairly clear but whenever I boot the device it never connects to http://hassio.local:8123. no matter how long I wait.

I thought I was going crazy so I’ve tried it a few different ways, from using etcher to flash a brand new SD card, to installing raspbian on the SD card then flashing the image to install.

I’ve checked and am on a Pi 3 Model B, am using the image for Raspberry Pi 3, plugging into the ethernet cable and check for the IP address each time to see if i can connect via PuTTY (after the image is flashed, I never can).

Where am I going wrong?

Check your power adapter. i had an underpowered one that kept me from getting on the network. Make sure it’s at least 2.5a

I’d also try a monito plugged in as it looks to me like it’s not even booting. With a monitor you will at least see it doing something when you first boot it. I bet the image isn’t flashed properly.

Try using the IP address instead of hassio.local

That fixed it for me as well. I have seen that advice here on the forum a few times, perhaps good to add it to the instructions page?