Hass.io on Synology DSM (native package)

Tags: #<Tag:0x00007f73ae078f68> #<Tag:0x00007f73ae078ea0>

I have got the same with some other addons. Maybe we can ask the hassio team.

The hassio container needs some magics so it is not as easy as managing a docker container.

See here

Yes it is a bit magical.

Hi all,

I just installed it and started to play with it.

One question for synology users: do you still allow synology to create ssl certificates or use let’s encrypt addon?

The reason for this question is that I noticed that many addons (tasmoadmin, esphome etc) require fullchain.pem and privkey.pem to work and those created by synoloy are hidden in system folders.

Thank you in advace

Installation worked smoothly, how do I migrate my configuration, devices etc from HomeAssistant docker?

BTW got a lot of errors in the hass.io logs, will post it later.

I think there is an issue with the stream component and this package. I migrated over from regular home assistant and every time I try to view the cameras some of them pull up but then Hass.io freezes and I get connection lost. Reconnecting…

Stopping the container and restarting it gets me back up and running but there are frequent disconnects. I think someone else is seeing this too now…

My streams work in both home assistant and this Hassio version running on my Synology. Running 2 wyze cams (rtsp firmware) and one xiaofang (rtsp stream too).

Do those add ons still work within Hassio? I use the Synology provided SSL. Could always go back to duckdns if it’s an issue though. Are you able to run the node red add on? I can’t run that one for some reason.

Yes both tasmoadmin and esphome work outside my lan. Question is: am I protect or those app are a sort of frames so their services are exposed?

Regarding node red I’m not using it. Sorry.

Then I noticed another thing: by default the app install version 0.96b. I don’t know if it can be changed or maybe there’s a error with the image provided in docker hub.

This is handed by the hassio-supervisor, I’ve not done anything special to dl the beta.

Does this package include drivers for usb? Today I`m using the Domoticz package before starting HA (After reboot of the nas).

And regarding the error messages around linux runtime spec devices: error gathering device information while adding custom device this is from another thread:

It seems like HassOS for those systems is missing the tun support in the kernel

All in all this is working great.

either take a snapshot from your old system and then copy the backup over, or once you can browse the file structure on the NAS location, simply copy the files over…

1 Like

@fredrike thank you!!!
very much appreciated!!

4 posts were split to a new topic: DarkSky rate limit issues

ok will try this later.

Another point, I intalled NodeRed, so far so good, when I am editing nodes there is the auto-complete for the entities, but there is only shown the entitiy name not the friendly name, is this a normal behavior?

not sure, browse the forum and post in a seperate thread if need be as this is off-topic to this thread…

I did install the SPK file.
In the hassio_supervisor docker details, ik keep getting errors/warnings like:

Cannot connect to host version.home-assistant.io:443 ssl:None [Try again]e
Can’t fetch freegeoip data: Cannot connect to host … :80’ ssl:None [Try again]e
fatal: unable to access ‘https://github.com/home-assistant/hassio-addons/’: Could not resolve host

Any idea what might be wrong ? I have the original home-assistant running in docker (was stopped during the installation of the synology package hassio_x64-6.1_20190709-1.spk)

could not resolve host is an DNS error. Have not seen that since I realized that there was a routing bug in the Synology version of Docker. Not sure what is going on now though.

Hi
Can you please guide me with the steps and screenshots of installing this. I have downloaded the .spk file from your desktop.

I guess you can use --dns parameter for setuping dns servers for the container. Isn’t it?

Hey thanks, I installed this to trial it but decided to go back to my original Docker Container.

Should note that installing this package will remove any existing HA Docker Containers (probably if just if they have the same name I’m assuming) That was a bit annoying but no big deal.

However, since uninstalling and restarting my NAS I still have in Resource Monitor, under the Network tab (and in the Resource Monitor widget) an additional Network Interface called hass.io

How can I remove this? There isn’t any reference to it in the Control Panel - Network settings that I can see.

Cheers,
Josh