Hass.io restart failed - how to resolve

I just initiated a restart from the configuration panel. (Hass.io v0.50.2)
hass never came back up after the restart.
I needed to login into the hass.io host and run:

docker restart homeassistant

I noticed that this happened a few times in the past with normal hass on docker, too. (restart from config panel)
Just posting here for folks using hass.io who may not be familiar with docker.

1 Like

I second that, whichever method i try to restart either bz script or bz using the integrated method, it wont reboot. LOG file doesnt show anything

I have the same experience, no logs and never restarts. I have to manually restart the RPi box (v0.50.2 but was same with Hass.io v0.50.1).

I’m getting similar problems. If I try to restart my Raspi from hassio configure using the button at the bottom, sometimes it works but about half the time it stays rotating and does nothing. The pi is still running, mqtt still running, influxdb and grafana still running. If i then try to restart using putty through ssh addon it stops the putty connection but still doesn’t shutdown and restart. The only way out seems to be pulling the plug. It’s making me nervous about my sd card and putting me off trying to make configuration changes and additions.

Hi,

I also have had the issue since 0.50.1, and still occurring on 0.52.0.

Interesting. I’ve just installed hass.io for the second time this evening and came to the same problem.

I’ve tried to enter the zwave config to… well - config; did it, restarted via webui but never got the webui back. A more than a couple of restarts, a hassio homeassistant check or two and hassio homeassistant start later - still no webui. If I try docker restart homeassistant I get “docker: not found”

I’ve, however, found an error by doing hassio homeassistant logs saying the following:

2017-10-07 21:49:54 ERROR (MainThread) [aiohttp.server] Error handling request
Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/aiohttp/web_protocol.py", line 278, in                data_received
    messages, upgraded, tail = self._request_parser.feed_data(data)
  File "aiohttp/_http_parser.pyx", line 274, in aiohttp._http_parser.HttpParser.               feed_data (aiohttp/_http_parser.c:4364)
aiohttp.http_exceptions.BadStatusLine: invalid HTTP method

Also, no luck with manual restart.

Please be advised I’m a total noob.

Any ideas? A reinstall? Again?

Hey I was having the same sort of problem,

1 of 2 things fixed mine,

  1. I replaced my SD card (Doubt that fixed It but did it anyway)
  2. When I need to reboot home assistant I access Hass.io from the sidebar and then in the top right corner use the 3 vertical dots and reboot it from that menu. I have rebooted mine probably 20 times this way, before the first reboot would knock mine out.

hopefully that helps a bit.

Wooohooo! Thanks for that. I’ve reinstalled since and got to the point where I can reboot as much as I like with zero crashes. However, none of my (three in total for now) z-wave nodes didn’t report hafl the things they should have (no names, no manufacturer name, entity id.,…) until… Until I’ve restarted the damn thing the way you wrote there. Now everything at least has a name. That’s another step fwd. Thanks once again!

I wish hass.i would disable any other way to restart from the UI…

1 Like

Thank you DavidK2016
Perfect.