Hassbian picture for known_devices

Hi All,

I am using hassbian and I have a few known_devices to which i want to add picture:.

When I’m using a picture from the web it works but when I’m trying to add a local picture it doesn’t.

I saw in the web that I need to put it in www folder but I don’t have a folder name www and I didn’t understand where should I create it (I tried in the same place where configuration.yaml is but it didn’t worked).

Any help will be greatly appreciated!

Create the folder ‘www’ where your configuration.yaml is.
In known_devices include the pictures with picture: /local/your_picture.png

Thanks :slight_smile:

i cannot get this to work.

Hassio 0.93.1

I created a www folder and placed the picture in there. It is only 25kb

I’m not using DuckDns as I see this fixed it for some but for now I’m not setting remote access everything local.

in my known_devices.yaml
my_iphone:
hide_if_away: false
mac:
name: my iPhone
picture:/local/me.jpg
track: true

Can you open the picture at

http://<ip_or_hostname>:8123/local/me.jpg

Restarted HA after creating the www folder?

EDIT: There should be a space between picture: and /local.me.jpg

1 Like

thanks! the issue was the space between picture: and /local/

good to know how to test for the picture too.