Hassio 0.60.0 - NMAP is not updating - SOLVED

Hello all. I’m having strange issue with nmap on my hassio installation. Nmap is sometimes working and sometimes not. One of my scanned devices is still showing “home”, even though device’s WIFI is disabled. I can’t figure out what is the problem here. At first I thought maybe my configuration.yaml or know_devices.yaml contains some bad entries, but then I realized that everything was absolutely fine for couple of days.

My configuration.yaml

  • platform: nmap_tracker
      interval_seconds: 15
      consider_home: 180
      track_new_devices: yes
      scan_options: " --privileged -sP "

My known_devices.yaml

hide_if_away: false
mac: 48:13:7E:C4:52:05
name: Ola
track: true
vendor: Samsung Electronics Co.,Ltd

hide_if_away: false
mac: E0:DB:10:11:3D:ED
name: Wojtek
track: true
vendor: Samsung Electronics Co.,Ltd

Nmap itself seem to be working fine. Below scan shows nmap result for my phone WIFI enabled and disabled. Nmap was showing two different results while hassio frontend was always showing “home”.

➜ ~ nmap -F

Starting Nmap 7.60 ( https://nmap.org ) at 2018-01-02 19:53 CET
Nmap scan report for
Host is up (0.019s latency).
Not shown: 90 filtered ports
22/tcp closed ssh
23/tcp closed telnet
80/tcp closed http
110/tcp closed pop3
113/tcp closed ident
139/tcp closed netbios-ssn
554/tcp closed rtsp
1025/tcp closed NFS-or-IIS
1723/tcp closed pptp
5900/tcp closed vnc
MAC Address: E0:DB:10:11:3D:ED (Samsung Electronics)

Nmap done: 1 IP address (1 host up) scanned in 2.80 seconds
➜ ~ nmap -F

Starting Nmap 7.60 ( https://nmap.org ) at 2018-01-02 19:54 CET
Note: Host seems down. If it is really up, but blocking our ping probes, try -Pn
Nmap done: 1 IP address (0 hosts up) scanned in 1.18 seconds
➜ ~

I’m running HASSIO 0.60.0 on PI3.

Any ideas or suggestions?

Do you have a Apple computer and use Safari as browser?


I have tested it on win 10 and chrome browser and on android smartphone. On both I can see same problem

try change the scan option:

scan_options: " -sP --host-timeout 10s"


Thanks a lot :slight_smile: It seems to be working fine. I will test it for couple of days and report back.


As promised, I’m coming back with confirmation. All is working absolutely fine now. I’m still having an issue with my smartphone not getting connected immediately after it appears in WIFI range - but this is a separate issue and I need find solution elsewhere.