Hassio does not detect Harmony Hub

Hi, I have installed Hassio on my Raspberry Pi 2 and have got it working with presence detection, my IP camera and created an automation that turns off motion detection whenever anyone is home. All good so far.

My problem is that Hassio will not detect my Harmony Hub. I know detection is working because it successfully detects my Plex server.

The issue might be because the Harmony hub is in another network segment (for IOT devices) whereas my Plex server is in the same segment. To try an eliminate this being the issue, I have created a firewall rule that allows the Hassio server fulls access to all my other network segments (the camera is in the IOT segment).

Can anyone provide assistance to help with this issue?

You can add a host IP address to your configuration. I don’t have my hubs on a different network so I can’t say for sure if this will work, but I would imagine that telling HA where to look for your hub should help. Since you can’t set up a static IP address in the hub, you’ll want to use an IP address reservation in your router so your hub is always assigned the same address.

I’m running home assistant, but had the same issue. I have two hubs, and had to just add them manually by ip. Mine were on the same network.

Thanks for the feedback.

I have set a static IP for the hub (via DHCP reservation) and and have told Hassio what that IP is, however, it still does not create a harmony_REMOTENAME.conf file in the config directory.
Without this file, i cannot see any of the activities or devices configured on my Harmony Hub.

is your remote getting discovered? Does it show up in the states tab? If so try to do a sync inside the harmony app.

I ran into this issue when i replaced my router. Previously my harmony hub was picked up automatically. after the router change i had to give it a static IP and enter it manually into my hass.io config file.

When discovery is turned on, the Harmony appears in the known_devices.yaml. Nothing appears in the states table and there still is no harmony_NAME.conf file created in the config directory.

I tried turning off discovery, and manually added the remote config in my configuration.yaml file

  - platform: harmony
    name: !secret harmony_name
    host: !secret harmony_ip

and still nothing appears in the state table and conf file is not created.

This is getting extremely frustrating!

Hmm this sounds similar to an issue we saw earlier on discord. Are you by chance defining more than 1 remote? If so try looking at these docs to see if you need to make any adjustments to your configuration.yaml

Also another test you can do is move one device off the other network temporarily and confirm if hassio can see it on the same network plex is on. That may tell you if you have another firewall rule or something to look out for.

I am only trying to set up one remote and I have followed that page that discusses adding devices to HA still with no luck.

As a test, I removed everything from configuration.yaml file except the declaration of the remote (as above in my previous post) and when I restarted Hassio the following appeared in my log file:

2018-04-30 10:42:49 WARNING (MainThread) [homeassistant.components.remote] Setup of platform harmony is taking over 10 seconds.
2018-04-30 10:43:39 ERROR (MainThread) [homeassistant.components.remote] Setup of platform harmony is taking longer than 60 seconds. Startup will proceed without waiting any longer.

Is there any way I can see why this component is taking so long?

Managed to solve the issue myself finally.

Reconfigured my network so that my IOT segment is behind its own router. Then I created a port forward on the IOT router for TCP 5222 and HA instantly detected the Harmony and created the relevant conf file.

Hi, I’m new to home assistant and like to revive this old thread :wink:
Trying to add my two harmony hubs and added “discovery:” to my configuration file.
However, nothing found (but my AVM Fritzbox).
HA runs in a docker container on my Synology, using the HOST network, on port 8123.
Not sure what do to do with port 5222 as it’s all the same subnet.

You can add them by their ip addresses:

  - platform: harmony
    name: Vancouver
  - platform: harmony
    name: Seattle

Thanks, this worked. But using discovery would have been more charming :wink:

Unfortunately since home assistant works from docker environment and these days routers are equipped with hefty firewalls discovery is hit and miss. My suggestion is to give every smart device an static IP address and you just have to configure them once.

I must admit I’m not a docker expert and on top new to HASS, but the docker container is set to use the host network. It’s not natted. Well… nevermind. It works. So far my experience with HASS is very very good, coming from openHAB. It’s awesome that the android app can connect directly to my local server without using any cloud service (incl. notifications!)

1 Like

Indeed the only reason I have openHab running beside HA is insteon. Also another suggestion, from the get go don’t bother writing script just jump to node rode. Makes it 10X easier to create and manage.

Indeed it would have been nice to do the automagic.
I’m also running HASS from a Docker on a Synology and it does recognise my HUE hub, HEOS speakers but not the Harmony Hub. It seems that there is something different in the code checking for the Harmony hub or it is just late in responding.

Anyhow above code does solve the issue.

1 Like