Hassio installed in Docker don't work

I have some problem with my Hassio installation in a Docker.
Have installed Docker on a ubuntu 18.04 machine. Also installed Portainer to manage the dockers.
Docker is working fine.
Install the Hassio with following script.

curl -sL "https://raw.githubusercontent.com/home-assistant/hassio-installer/master/hassio_install.sh" | bash -s

From Portainer I can see that the Hassio containers has been installed.

The hassio_supervisor container seems to have started, see log.

The log for container homeassistant.

The log for container hassio_dns.

But I can’t reach the Home Assistant frontend with the ip-address:8123.

Does anyone see what the problem is?

How long have you waited to check access? Sometimes it could take a while.

Based on the logs, the system is up and running.

Do you have UFW running?

1 Like

finity, I have waited over a day. I think it should be up and running by then!

1 Like

flamingm0e, I have only installed the ubuntu, have not done any configuration.
I don’t know the status of the UFW.
How should the UFW be configured?

UFW shouldn’t be configured or running while you are trying to troubleshoot. UFW is a firewall on Ubuntu.

Are you using DHCP or Static IP on this Ubuntu server?

1 Like

I use a Static IP on the Ubuntu server.
Or I’m actually using Ubuntu desktop, will that be any problem?

If you’re using a static IP, are you sure you have your subnet, gateway, and DNS correct?

I have following settings.

Gateway same as router IP
I’m little unsure about the DNS. Should it be the same as the gateway or should I set it to something else?

Whatever runs your DNS for your network. I don’t know, I don’t run your network. Sometimes it’s the router, sometimes it’s another server on the network, sometimes it’s a public DNS…

I also use the DNS of
So I think the network setting is okey!
Can I do someting locally on my ubuntu computer to verify that everything is working correct?

I can see from the Portainer that the homeassistant container doesn’t have any ip-address, is that correct?

home assistant runs as net=host so it will not show an IP address or port in Portainer or in docker ps -a

what happens if you run curl -I http://localhost:8123/ or curl -I http://ipaddress:8123 directly on the Ubuntu host?

Maybe stupied question but should I replace “localhost” and “ipaddress” in the commandes?
If yes, to what?

localhost should stay as is

ipaddress should be the IP ADDRESS of the machine you are running this on. Based on your comment earlier,

curl -I http://localhost:8123/

Give following result:

curl -I

Give following result:

Seems that it is not working!

definitely not responding correctly.

Okay, something wrong!
Any more tips what to do?
Should I reinstall Hassio ?
I have already reinstalled Hassio ones, I guess it will be the same result one more time!
If I reinstall Hassio

You don’t really “reinstall” hassio.

You can stop the services, remove the docker containers, and restart the services

Yes, your are right flamingm0.
I only removed the container and reinstalled the Hassio with following command.

curl -sL "https://raw.githubusercontent.com/home-assistant/hassio-installer/master/hassio_install.sh" | bash -s