Hassio letsencrypt addin won't renew

I just tried to renew my certificate. It has renewed perfectly before. Here is the log:

starting version 3.2.4
Saving debug log to /var/log/letsencrypt/letsencrypt.log
-------------------------------------------------------------------------------
Processing /data/letsencrypt/renewal/my-domain.duckdns.org.conf
-------------------------------------------------------------------------------
expected /data/letsencrypt/live/my-domain.duckdns.org/cert.pem to be a symlink
Renewal configuration file /data/letsencrypt/renewal/my-domain.duckdns.org.conf is broken. Skipping.
-------------------------------------------------------------------------------
0 renew failure(s), 1 parse failure(s)
No renewals were attempted.
Additionally, the following renewal configuration files were invalid: 
  /data/letsencrypt/renewal/my-domain.duckdns.org.conf (parsefail)

In the addin in Hassio I have this:

{
  "email": "[email protected]",
  "domains": [
    "my-domain.duckdns.org"
  ],
  "certfile": "fullchain.pem",
  "keyfile": "privkey.pem"
}

This happened to me to after a snapshot restore. I uninstalled the addon, deleted the keyfiles, reinstalled, and got a new one. It only takes a minute or so.

Not sure how to fix it without doing that, sorry.

3 Likes

Thanks. I’ll give that a go. not too much trouble

That worked. I didn’t delete the keys though. On reinstall, it had removed the 443 option from network and it just worked like it should.
Thanks for the advice

What did you do? disable 443 to 8123 option from the router and restart the plugin?