HASSIO network down after router reboot

Same issue here

I have schedule to restart my Synology router time after time.
Hassio was not affected on WiFi channel, but then I decide to connect it over Ethernet directly to router got this issue too
Hassio became unacceptable with IP or DNS name in browser, but for some reason it accessible over SSH (ipv6 I suppose)

Just edit file /etc/NetworkNamager/system-connections/[config file name] over SSH with remark example provided, and it fixed my issue

Thanks!

2 Likes

Just a confirmation that this is STILL a problem as of now (end of June 2020) with the latest version of Home Assistant on a Pi 4B. I’ve had to power cycle the Pi every time the router is reset.

As to use cases for rebooting the router:

  1. On very rare occasions it will go out to lunch. It went out to lunch yesterday or today after being up for 1-2 months straight.
  2. Firmware upgrades. If you happen to try and live on the bleeding edge with OpenWRT from git master, you might be flashing relatively often. This is the root cause for the second failure of Home Assistant to come back up on the network.

It drops off the network as far as DHCPv4 (no lease shown any more), there is an active DHCPv6 lease. This is, like all others, with wired and not wireless. Also, like everyone else - no other device on the network behaves like this.

I confirm that now it happens to me too RPI 3B + with the latest version, and now I’m a little messed up. in a few days I have to leave on vacation.

Yeah I confirm that as of Aug 12th, 2020 this issue is still the case.
After router reboot.
My Pi4 just can’t be reach even via IP address.
the log goes “Link lost; Power save enabled.” that is fine, but then after router is up, my Hassio should detect that and pick it up.
and that is with wired connection + Static IP Address.
Router is TP-Link Archar C3200.
*
update: I unplug the Ethernet and re-plug, nothing happens.
*
Update:
Then fix by making a Wi-Fi profile USB stick and plug that in. Then unplug the Ethernet cable, count to 10, then re-plug. Now it’s working, accessible via static IP address.
*
I have a timer to turn off router daily during sleep when no one is using WiFi.

I think I have the same kind of problem:

Today the elecricity went down and the raspberry apparently rebooted before the wifi connection was ready.
The strange thing is that Home Assistant DOES work, since my devices are accessible and perfcectly working through Google Home or Homekit, which rely on the home assistant MQTT bridge and other things. But I cannot acces the Home Assistant interface neither via desktop nor through the iOS app, same thing with DDNS domain and internal static IP addres (that, as i can see from the router, is the same as always).

Any ideas? It is pretty serious as I had to reboot the entire raspberry to make it work again, and it is pretty annoying since if I’m away and this happens again i would not have any chance unless to open the SSH port on my router, which is the last thing i would do!!