Hassio not working after power cut

hi all,

been running hassio on ubuntu server 1804, today we had a power cut and after that hassio didn’t come back up.

I can’t get to the smb share but I can ssh to the ubuntu server and access the files.

how can I get my hassio working again without having to build a new server?


What does docker report?

if you can get ssh in, maybe you should run some commands like ‘hassio host reboot’ or ‘hassio ha restart’. I think there’s another command to check status of HA, I forget. Good luck with everything.

How do I check that?

If I run any hassio commands ubuntu says hassio command not found

That is because you are not inside the hassio container.

Try as a starter:

docker ps -a

And post back the result.

162eb544b08c homeassistant/qemux86-64-homeassistant “/bin/entry.sh pytho…” 15 hours ago Created homeassistant


docker run 162eb544b08c

sorry for the delayed reply, was at work:

Unable to find image '162eb544b08c:latest' locally
Error response from daemon: pull access denied for 162eb544b08c, repository does not exist or may require       'docker login'.

that should be

docker start 162eb544b08c

getting somewhere now:

Error response from daemon: could not copy source hosts file /etc/hosts to /var/snap/docker/common/var-lib-docker/containers/162eb544b08c2bffc8081974be7d7f3683a10b381deacc7bfcbf3e3a94e23baa/hosts: write /var/snap/docker/common/var-lib-docker/containers/162eb544b08c2bffc8081974be7d7f3683a10b381deacc7bfcbf3e3a94e23baa/hosts: no space left on device

Error: failed to start containers: 162eb544b08c

You’re running docker through SNAP?

Install docker-ce the official way.

I installed it using these instructions: https://gist.github.com/frenck/32b4f74919ca6b95b30c66f85976ec58

Then why does your error log suggest you are running docker from SNAP? The instructions you linked to would have installed docker-ce the correct way.

pass, I copied and pasted the commands

So, you think that /var/snap is part of normal docker-ce?

I don’t know, unfortunately i don’t know enough about docker, it worked perfectly until the power cut

This isn’t about docker, it’s about how docker is running

snap list

Name Version Rev Tracking Publisher Notes
core 16-2.36.3 6130 stable canonical✓ core
docker 18.06.1-ce 321 stable canonical✓ -

there’s docker-ce in snap…

Try removing the snap and installing it correctly.