Hassio on Raspbian, privileged access to serial

Hello all. I am trying to use a Raspberry Pi3 with 7" screen as a combined Hassio and Touch-screen control panel for automation in my boat. The need for a X desktop makes me install Raspbian but at home I use Hassio and I want that simplicity also in the boat (for upgrades, extensions etc). Problem is that I use a Zigbee tophat (Elelabs) on the GPIO headers. I have disabled bluetooth (uenable_uart=1 and dtoverlay=pi-disable-bt in config.txt) and installed docker, hassio running great. ZHA configured but I get error setting up serial device /dev/ttyAMA0 in the log. Could this be because of the need for privileged access? How could I get the supervisor to run the HASS.io container with for instance --privileged or --device=/dev/ttyAMA0?

Very sorry but I am not very experienced with docker so this is a bit outside my comfort zone. If anyone has any ideas to share I would be very happy!