Hassio terminal broken after 57.1 and 57.2 updates, on 2 Pi Hassio hosts

I have been using this since my first hassio install, performed the 57.2 update and now it spawns a terminal window but never a prompt. My backup that was upgraded to 57.1 also does the same thing. Keystrokes do not wake it up. I uninstalled it and reinstalled with the same results. Have tried numerous reloads as well.

Install and start log looks ok, to me…

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] 10-hassio: applying... 
[fix-attrs.d] 10-hassio: exited 0.
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] 00-banner.sh: executing... 
-----------------------------------------------------------
 Hass.io Add-on: Terminal v2.0.2
 Terminal access to your Home Assistant instance via the web
 From: Community Hass.io Add-ons
 By: Franck Nijhof <[email protected]>
-----------------------------------------------------------
[cont-init.d] 00-banner.sh: exited 0.
[cont-init.d] 01-log-level.sh: executing... 
Log level is set to INFO
[cont-init.d] 01-log-level.sh: exited 0.
[cont-init.d] 02-updates.sh: executing... 
INFO: You are running the latest version of this add-on
[cont-init.d] 02-updates.sh: exited 0.
[cont-init.d] 10-requirements.sh: executing... 
[cont-init.d] 10-requirements.sh: exited 0.
[cont-init.d] 30-link-common-dirs.sh: executing... 
[cont-init.d] 30-link-common-dirs.sh: exited 0.
[cont-init.d] 40-zsh.sh: executing... 
[cont-init.d] 40-zsh.sh: exited 0.
[cont-init.d] 50-user-ssh-folder.sh: executing... 
[cont-init.d] 50-user-ssh-folder.sh: exited 0.
[cont-init.d] 80-user-packages.sh: executing... 
[cont-init.d] 80-user-packages.sh: exited 0.
[cont-init.d] 81-user-scripts.sh: executing... 
[cont-init.d] 81-user-scripts.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
starting version 3.2.2
[services.d] done.
INFO: Starting the ttyd daemon

Any clues? Willing to help troubleshoot, but will need advice to do it.

Anyone, really would like this to work again. Can still ssh into the box but this interface is so handy.

More info…
I added a username and password to the config file and restarted terminal 2.0.2. When I hit the web page it prompts for a name and password, which it takes but it never gives me a prompt.

Is there a way to downgrade my hassio install or terminal install?

Latest log from terminal restart.

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] 10-hassio: applying... 
[fix-attrs.d] 10-hassio: exited 0.
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] 00-banner.sh: executing... 
-----------------------------------------------------------
 Hass.io Add-on: Terminal v2.0.2
 Terminal access to your Home Assistant instance via the web
 From: 
 By: 
-----------------------------------------------------------
[cont-init.d] 00-banner.sh: exited 0.
[cont-init.d] 01-log-level.sh: executing... 
Log level is set to INFO
[cont-init.d] 01-log-level.sh: exited 0.
[cont-init.d] 02-updates.sh: executing... 
INFO: You are running the latest version of this add-on
[cont-init.d] 02-updates.sh: exited 0.
[cont-init.d] 10-requirements.sh: executing... 
[cont-init.d] 10-requirements.sh: exited 0.
[cont-init.d] 30-link-common-dirs.sh: executing... 
[cont-init.d] 30-link-common-dirs.sh: exited 0.
[cont-init.d] 40-zsh.sh: executing... 
[cont-init.d] 40-zsh.sh: exited 0.
[cont-init.d] 50-user-ssh-folder.sh: executing... 
[cont-init.d] 50-user-ssh-folder.sh: exited 0.
[cont-init.d] 80-user-packages.sh: executing... 
[cont-init.d] 80-user-packages.sh: exited 0.
[cont-init.d] 81-user-scripts.sh: executing... 
[cont-init.d] 81-user-scripts.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
starting version 3.2.2
[services.d] done.
INFO: Starting the ttyd daemon

I can make it work now… but it is odd.

When using firefox I must open the terminal before I open my Hassio instance home page. If Hassio is open the terminal will always display a blank screen when loaded. My Hassio instance is running with SSL enabled. The terminal is not since it is not accessible from the outside world.

If Hassio is loaded the browser console reports:
SecurityError: The operation is insecure.
When I try to load the terminal.

If Hassio is not loaded in a tab and I open terminal, the browser console reports:
Websocket connection opened 192.168.1.6:7681:20:434
Enabling reconnect: 30 seconds 192.168.1.6:7681:20:1336