Heaty will die, Schedy be born!


#121

@thundergreen You probably could, but that clearly is not the intended way. I mean, what is the purpose of a thermostat if it can’t heat to a given target temperature?


#122

Don’t also…my house is 30 years old …and the AC is not that good


#123

@thundergreen But what you have really is a climate entity, right?


#124

Yes…I use a custom component to control the AC via ir blasters (Xiaomi) …with all the Attributes needed


#125

i got ubuntu and i dont like docker at all.
i prefer venv.
i got 2x HA and 4x AD all in their own venv.


#126

@ReneTode Yes, that works as well of course. I just switched over from a venv-based setup to Docker last week and am testing how it performs. Apart from a 1 minute startup time on a Core i3-7100 I’m pretty happy with it, although just the Home Assistant docker image is 2.2GiB in size (yes, seriously). Maybe I’ll get back to the venvs later, but docker gives me some more flexibility in terms of macvlan networking so that all services can easily be placed in different subnets and firewalled correctly.


#127

I am using DietPi in a VM as the base - nice and lightweight

The problem I had with using a venv was working out how to update HA then it seemed very complicated to do so (that was a while ago though).

I don’t understand docker really but overall, it does just seem to work installing HA etc like this.


#128

I had exactly the same issue. I think the VM ran out of disk space and I could not expand the disk.


#129

huh?
with a venv you just give the command pip3 install --upgrade homeassistant
its just because its absolutely not complicated why i like it.
all you need to remember is to activate the venv before you give the command.


#130

Mmmm, exactly. If you are not used to using venvs, that bit complicates the issue. With hassio, I just click ‘upgrade’ in the web interface and it just works.


#131

right it is easier to click a button then to type 2 commands (which i dont remember but have in a document)
but you lose a lot of freedom over it.

  • you need to figure out how to install other stuff (pip isnt working anymore)
  • youre configuration gets modified for you, so if other make a mistake you got a problem
  • the supervisor updates automaticly, which caused that people had a problem in the past because they made an error or breaking change
  • you cant add comments in your config, because its overwritten
  • if appdaemon brings a new version you need to hope that frenck has the time to update the addon.
  • an addon is a piece of code around the existing program so an extra risk on errors with an update
  • etc.

i would never prefer that over typing 2 commands :wink:

but enough about that.
@roschi sorry that we hijacked your topic for something else (allthough you did help with that :wink: )
i guess its back on topic with your app.


#132

Yes I’d agree with much of what you say, but the harsh fact is that installing HA via hassio seems to be the way the HA project is going and installation in a venv has been relegated to ‘alternative installation methods’ (although what I did isn’t exactly mainstream).

This has been useful (I apologise as well for drifting OT @roschi) but it has helped me understand the underlying architecture. File it under YMMV :smile:. Thanks for your time.


#133

Hi all,

Especially to @DamianFlynn this should be interesting.

The statistical parameter collection finally has come to Schedy as well. It’s far more generic and allows to implement new parameters easily.

The docs: https://hass-apps.readthedocs.io/en/latest/apps/schedy/statistics/index.html

Would be great if some of you want to test it.

Best regards
Robert


#134

Awesome

Tonight’s work. I’ll be back tomorrow with initial comments. But first Thank You


#135

Awesome work! I just started migrating from domoticz to HA. In Domoticz I had my own kind of scheduler, based on LUA with text files for the schedules - butyour solution is waaaay more elegant!

I did a test setup with a switch and a virtual thermostat and it works fine. One thing I need are the statistics from heating to control my oil burner fir the central heating. current problem: as soon as I enable statistics, I get an error. I did simply this:

statistics:
  virtual_temp_delta:
    type: temp_delta
    rooms:
      virtual_room:

Now, when I restart appdaemon, I get the following error:

2018-11-23 12:24:49.154448 WARNING AppDaemon: ------------------------------------------------------------
2018-11-23 12:24:49.155177 WARNING AppDaemon: Unexpected error running initialize() for schedy_heating
2018-11-23 12:24:49.155581 WARNING AppDaemon: ------------------------------------------------------------
2018-11-23 12:24:49.159072 WARNING AppDaemon: Traceback (most recent call last):
  File "/home/homeassistant/appdaemon/venv/lib/python3.5/site-packages/appdaemon/appdaemon.py", line 1581, in init_object
    init()
  File "/home/homeassistant/appdaemon/venv/lib/python3.5/site-packages/hass_apps/common.py", line 90, in initialize
    self.cfg = self.Meta.config_schema(cfg)  # pylint: disable=not-callable
  File "/home/homeassistant/appdaemon/venv/lib/python3.5/site-packages/voluptuous/schema_builder.py", line 267, in __call__
    return self._compiled([], data)
  File "/home/homeassistant/appdaemon/venv/lib/python3.5/site-packages/voluptuous/validators.py", line 204, in _run
    return self._exec(self._compiled, value, path)
  File "/home/homeassistant/appdaemon/venv/lib/python3.5/site-packages/voluptuous/validators.py", line 286, in _exec
    raise e if self.msg is None else AllInvalid(self.msg, path=path)
  File "/home/homeassistant/appdaemon/venv/lib/python3.5/site-packages/voluptuous/validators.py", line 284, in _exec
    v = func(path, v)
  File "/home/homeassistant/appdaemon/venv/lib/python3.5/site-packages/voluptuous/schema_builder.py", line 811, in validate_callable
    return schema(data)
  File "/home/homeassistant/appdaemon/venv/lib/python3.5/site-packages/voluptuous/schema_builder.py", line 267, in __call__
    return self._compiled([], data)
  File "/home/homeassistant/appdaemon/venv/lib/python3.5/site-packages/voluptuous/schema_builder.py", line 589, in validate_dict
    return base_validate(path, iteritems(data), out)
  File "/home/homeassistant/appdaemon/venv/lib/python3.5/site-packages/voluptuous/schema_builder.py", line 427, in validate_mapping
    raise er.MultipleInvalid(errors)
voluptuous.error.MultipleInvalid: extra keys not allowed @ data['rooms']['statistics']['virtual_temp_delta']

I’m using the latest version from github - any idea what I did wrong?


#136

i guess you got something there that isnt allowed.


#137

But that’s what I don’t understand… here is the example from the documentation:

statistics:
  # Pick an arbitrary name for the parameter instance.
  upstairs_temp_delta:
    # The type of parameter as found in the actor'S documentation.
    type: temp_delta
    # More parameter-specific settings:
    rooms:
      bathroom:
      kidsroom:
    #...

and here is my code:

statistics:
  virtual_temp_delta:
    type: temp_delta
    rooms:
      virtual_room:

the problem is purely in the statistics part, as soon as I remove it, everything works fine…:thinking:


#138

Gah, I hate yaml. apparently the problem was that ‘statistics:’ had the wrong indention… :roll_eyes:
Stupid me, could have checked that before :tired_face:


#139

Hrm… i have run into the next issue. Syntax-Wise, my schedule seems to be coorect now, but it’s still not working. The Logfile shows the following warnings and errors for all my thermostats:

2018-11-23 17:36:31.592066 WARNING schedy_heating: !!! [R:Arbeitszimmer] [A:climate.arzi_heizung] Thermostat has no attribute named 'operation_mode'. Available attributes are ['value_id', 'attributes', 'last_changed', 'temperature', 'supported_features', 'context', 'min_temp', 'node_id', 'max_temp', 'entity_id', 'value_instance', 'state', 'last_updated', 'value_index', 'friendly_name', 'current_temperature']. Please check your config!
2018-11-23 17:36:31.597674 WARNING schedy_heating: !!! [R:Arbeitszimmer] [A:climate.arzi_heizung] Attributes for thermostat contain no 'operation_list', Consider disabling operation mode support.
2018-11-23 17:36:31.604003 INFO schedy_heating: --> [R:Arbeitszimmer] [A:climate.arzi_heizung] Attribute 'operation_mode' is None.
2018-11-23 17:36:31.609865 ERROR schedy_heating: !!! [R:Arbeitszimmer] [A:climate.arzi_heizung] Unknown operation mode, ignoring thermostat.

The thermostats are Devolo Home Control Thermostat Valves (basically the same as the Danfoss ones except that they also report the temperature back)
Heaty seems to have a possibility to disable the operation modes - but Schedy doesn#t seem to support that?


#140

Hi @blitzkneisser

Your thermostats don’t report their operation mode back. That’s not nice, but also shouldn’t be a too big issue.

Disabling operation mode support works in Schedy as well… https://hass-apps.readthedocs.io/en/latest/apps/schedy/actors/thermostat/index.html#configuration

Look for supports_opmodes.

You can disable it in the default actor template to have it applied to all thermostats at once.

Best regards
Robert