Heatzy Compoment

Forget my last comment
Actually it does the same event of the last refresh was 1min ago.
But I think you’re right that’s an UI issue.
I checked on the Heatzy app, and when changing the operation mode from HASS, it sends the operation mode properly, but doesn’t reflect it in HASS.

Hi,

@tmz42 Thanks a lot for your great jobs!

I have the same issue that @Nicolas_B. I run the last version 0.86.4 on a docker (HASS is still on test, my main setup is still on Jeedom). If I can help for fix this, feel free to ask :).

@tmz42 Did you manage to use your heatzy module with the generic thermostat?
On the doc, it seems that the generic thermostat need a toogle switch to activate the heating.
HASS apears to use HEAT, COOL or OFF operation, but since heatzy use CONFORT, HGEL…
Do you know if it’s possible to modify this on heatzy compoment?

Hi shellux,

Sorry, I won’t be able to send you the details of the config for some time (on vacation for two weeks), but the generic thermostat works well. I use a template switch to control the Heatzy combined with a mija bt sensor for the temperature.

@shellux A new Heatzy custom component has been created
Available here : https://github.com/Devotics/heatzy-home-hassistant
Works like a charm. You can also use the “on / off” mode and “vacation” mode.

1 Like

Hi @tmz42

Can you share your template switch / generic thermostat?

Thanks :slight_smile:

@shellux, here’s my configuration :slight_smile:

Basically :

  • I have a MQTT sensor for the temperature
  • I have a template sensor that gives the state of the Heatzy to the template switch
  • The template switch switches between CONFORT (ON) and ECO (OFF)
  • The generic thermostat glues everything up and works in Lovelace
# Template sensor
sensor:
  - platform: template
    sensors:
      etat_heatzy_salon:
        value_template: '{{ states.climate.salon.attributes.operation_mode }}'
        friendly_name: "Etat du chauffage du salon"

switch:
- platform: template
  switches:
    heatzy_salon:
      value_template: "{{ is_state('sensor.etat_heatzy_salon', 'CONFORT') }}"
      turn_on:
        service: climate.set_operation_mode
        data:
          entity_id: climate.salon
          operation_mode: 'CONFORT'
      turn_off:
        service: climate.set_operation_mode
        data:
          entity_id: climate.salon
          operation_mode: 'ECO'

climate:
  - platform: heatzy
    username: '[email protected]'
    password: '[email protected]'
  - platform: generic_thermostat
    name: Thermostat Salon
    heater: switch.heatzy_salon
    target_sensor: sensor.mqtt_temperature_salon 
    min_temp: 14
    max_temp: 22
    ac_mode: false
    target_temp: 19
    cold_tolerance: 0.3
    hot_tolerance: 0
    min_cycle_duration:
      seconds: 60
    initial_operation_mode: "off"
    away_temp: 15.5
    precision: 0.1

Thanks a lot!

Hello since the last update of home assistant 0.92 this custom component didn’t work… any update can be found ?

Any idea ?

Hi 5chacha5,

Sorry, I had not seen the issues since I just upgraded to 0.94… It’s fixed now for me (added manifest and fixed other issues).

hi

In may I’ve created a wipe init.py and that works perfectly

Thank you

Bonjour, pouvez-vous m’aider à installer votre plugin ? je pense avoir fais une erreur mais je ne sais pas où

Hello, can you help me install your plugin? I think I made a mistake but I do not know where

1 Like

Hi evereybody, i dont understand how to install this device. Can you help me please ? Thanks

Hi
I don’t know if the topic is still open, but I can’t use Heatzy with Home Assistant.

When I put a simple thermostat tile I have no possibility to set the temperament and the heating mode.

Thanks for your help!

Hello,

Does your config still work ?

I created sensors inspired from yours, replacing operation_mode by preset_mode as the former does not exist anymore but still not working. :frowning:

Any idea ?

EDIT: Managed to make it work actually, here is my config :slight_smile:

################################################
## Integration
################################################
climate:
  - platform: heatzy
    username: !secret heatzy_username
    password: !secret heatzy_password
  - platform: generic_thermostat
    name: Thermostat Chambre
    heater: switch.heatzy_bedroom
    target_sensor: sensor.0x00158d0004601664_temperature
    target_temp: 20
    min_cycle_duration:
      seconds: 60
    initial_hvac_mode: "off"
    away_temp: 15.5
    precision: 0.1

################################################
## Template sensor
################################################
sensor:
  - platform: template
    sensors:
      heatzy_bedroom_state:
        value_template: '{{ states.climate.chambre.attributes.preset_mode }}'
        friendly_name: "Etat du chauffage de la chambre"

################################################
## Switch
################################################
switch:
- platform: template
  switches:
    heatzy_bedroom:
      value_template: "{{ is_state('sensor.heatzy_bedroom_state', 'comfort') }}"
      turn_on:
        service: climate.set_preset_mode
        data:
          entity_id: climate.chambre
          preset_mode: 'comfort'
      turn_off:
        service: climate.set_preset_mode
        data:
          entity_id: climate.chambre
          preset_mode: 'eco'

As said above, I replaced operation_mode by preset_mode and ‘CONFORT’ and ‘ECO’ by ‘comfort’ and ‘eco’.
I am not using the generic thermostat for now though, just using the switch.

1 Like

Hi,

Here is my current conf with Devotic’s Heatzy component (worked the last time I checked, haven’t turned on the heat since March ;)).

I have a switch that… well, switches from away to comfort and a generic thermostat using that switch.

# Climate
- platform: generic_thermostat
  name: Thermostat Chambre
  heater: switch.chauffage_chambre
  target_sensor: sensor.mi_temperature_chambre
  min_temp: 14
  max_temp: 22
  ac_mode: false
  target_temp: 17.5
  cold_tolerance: 0.3
  hot_tolerance: 0
  initial_hvac_mode: "off"
  away_temp: 15.5
  precision: 0.1
# Switches to turn Heatzy on/off
- platform: template
    chauffage_chambre:
      value_template:  "{{ is_state_attr('climate.chambre', 'preset_mode', 'comfort') }}"
      turn_on:
        service: climate.set_preset_mode
        data:
          entity_id: climate.chambre
          preset_mode: 'comfort'
      turn_off:
        service: climate.set_preset_mode
        data:
          entity_id: climate.chambre
          preset_mode: 'away'
1 Like

Hello everybody,

I get a http 400 error in the log.

Logger: custom_components.heatzy.authenticator
Source: custom_components/heatzy/authenticator.py:34
Integration: heatzy
First occurred: 8:44:40 (1 occurrences)
Last logged: 8:44:40

Heatzy API returned HTTP status 400, response <ClientResponse(https://euapi.gizwits.com/app/login) [400 BAD REQUEST]> <CIMultiDictProxy('Allow': 'POST, OPTIONS', 'Content-Language': 'zh-cn', 'Content-Type': 'application/json', 'Date': 'Thu, 29 Oct 2020 07:44:40 GMT', 'Server': 'nginx', 'Vary': 'Accept, Accept-Language', 'Content-Length': '87', 'Connection': 'keep-alive')>

Sorry, just an error in creditials :sweat_smile:
Work like a charm !

1 Like